diff mbox series

[bug#46932] gnu: Add lr.

Message ID 20210304205828.146339-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46932] gnu: Add lr. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör March 4, 2021, 8:58 p.m. UTC
* gnu/packages/admin.scm (lr): New variable.
---
 gnu/packages/admin.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Nicolas Goaziou March 5, 2021, 4:24 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/admin.scm (lr): New variable.

Applied. I removed "new" from description.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 2ca99774b8..75f4366fa0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -2130,6 +2130,33 @@  environment variable is set and output is to tty.")
     (home-page "http://mama.indstate.edu/users/ice/tree/")
     (license license:gpl2+)))
 
+(define-public lr
+  (package
+    (name "lr")
+    (version "1.5.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.vuxu.org/lr/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1wv2acm4r5y5gg6f64v2hiwpg1f3lnr4fy1a9zssw77fmdc7ys3j"))))
+    (build-system gnu-build-system)
+    (home-page "https://git.vuxu.org/lr/about/")
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (delete 'configure))
+       #:tests? #f
+       #:make-flags (list (string-append "CC=" ,(cc-for-target))
+                          (string-append "PREFIX=" %output))))
+    (synopsis "Tool to generate customized file listings")
+    (description
+     "lr is a new tool for generating file listings, which includes the best
+features of ls(1), find(1), stat(1) and du(1).")
+    (license license:expat)))
+
 (define-public direvent
   (package
     (name "direvent")