diff mbox series

[bug#46928] gnu: Add emacs-stig-paren.

Message ID 20210304194025.93692-1-stefan@xsteve.at
State New
Headers show
Series [bug#46928] gnu: Add emacs-stig-paren. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör March 4, 2021, 7:40 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-stig-paren): New variable.
---
 gnu/packages/emacs-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Nicolas Goaziou March 5, 2021, 4:12 p.m. UTC | #1
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/emacs-xyz.scm (emacs-stig-paren): New variable.

Thank you.

I think there is an issue with this library: old revisions are not kept
around and file name is not versioned. It is unlikely it is updated
anytime soon, but if that ever happens, package definition will break.

Considering the features it provides has been part of Emacs for a long
time now (IIUC), do you think it is worth including?

Regards,
Stefan Reichör March 5, 2021, 7:59 p.m. UTC | #2
Hi Nicolas!

> Hello,
>
> Stefan Reichör <stefan@xsteve.at> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-stig-paren): New variable.
>
> Thank you.
>
> I think there is an issue with this library: old revisions are not kept
> around and file name is not versioned. It is unlikely it is updated
> anytime soon, but if that ever happens, package definition will break.
>
> Considering the features it provides has been part of Emacs for a long
> time now (IIUC), do you think it is worth including?

Thanks for your hint. I use stig-paren.el since more than 20 years. I
guess it worked better than the built-in show-paren-mode these days.

I thought it would be great to have all my emacs packages as part of guix.

Now I tried show-paren-mode again.
Here is what I came up with as stig-paren.el replacement:
,----
| (setq show-paren-style 'expression)
| (face-spec-set 'show-paren-match-expression '((t (:inherit show-paren-match :background "pale green"))))
| (show-paren-mode 1)
`----

That way my .emacs has grown a bit, but I no longer need stig-paren.el ;-)

You are correct, there is no need to add stig-paren.el to guix.

By the way: thanks for applying my other patches.

Thanks
  Stefan.
Simon Tournier March 5, 2021, 8:34 p.m. UTC | #3
Hi Nicolas,

On Fri, 5 Mar 2021 at 17:13, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> I think there is an issue with this library: old revisions are not kept
> around and file name is not versioned. It is unlikely it is updated
> anytime soon, but if that ever happens, package definition will break.

I think it is the same story as
<http://issues.guix.gnu.org/issue/46849>.  A mechanism to fallback to
an archiver (say SWH) seems missing.

BTW, I have no opinion about the inclusion of the package at hand. :-)

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 783f7790e9..85a612296c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -93,6 +93,7 @@ 
 ;;; Copyright © 2021 Alexandr Vityazev <avityazew@gmail.com>
 ;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
 ;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -385,6 +386,25 @@  for those who may want transient periods of unbalanced parentheses, such as
 when typing parentheses directly or commenting out code line by line.")
     (license license:gpl3+)))
 
+(define-public emacs-stig-paren
+  (package
+    (name "emacs-stig-paren")
+    (version "1.22")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://nicolas.francois.free.fr/"
+                                  "fichiers/emacs/stig-paren.el"))
+              (sha256
+               (base32
+                "1k4rd4k53c671akssza91p0d7psxagizc74nka3hi1pjkybmw6mn"))))
+    (build-system emacs-build-system)
+    (home-page "http://nicolas.francois.free.fr/fichiers/emacs/stig-paren.el")
+    (synopsis "Highlight matching parens for Emacs")
+    (description
+     "This package highlights matching parens (or whole sexps) for easier
+editing of source code, particularly lisp source code.")
+    (license license:gpl2+)))
+
 (define-public emacs-project
   (package
     (name "emacs-project")