diff mbox series

[bug#46921,PATCHES] Update python-sanic and dependencies

Message ID 20210304141549.GC2963@zpidnp36
State Accepted
Headers show
Series [bug#46921,PATCHES] Update python-sanic and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun March 4, 2021, 2:15 p.m. UTC
Hi,

attached patches update python-sanic to version 20.12.2, as
well as some of its dependencies, which cause few rebuilds.

Cheers,
Lars

Comments

Lars-Dominik Braun March 10, 2021, 11:35 a.m. UTC | #1
Pushed as 999a1cba5416bb2099e21d4fc55624d8ef2c7fa1.
diff mbox series

Patch

From 570715163b6a7686061cd24deaa007b3fb48c602 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Thu, 4 Mar 2021 14:48:28 +0100
Subject: [PATCH 4/4] gnu: python-sanic: Update to 20.12.2.

* gnu/packages/python-web.scm (python-sanic) [version]: Update to 20.12.2.
[arguments]: Relax dependency versions.
[native-inputs]: Add python-pytest-asyncio.
[home-page]: Update.
[synopsis]: Remove Python version.
[description]: Ditto.
---
 gnu/packages/python-web.scm | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b0268e5a31..edfff0c6a3 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5658,14 +5658,14 @@  as a Python package.")
 (define-public python-sanic
   (package
     (name "python-sanic")
-    (version "20.9.1")
+    (version "20.12.2")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "sanic" version))
        (sha256
         (base32
-         "06p0lsxqbfbka2yaqlpp0bg5pf7ma44zi6kq7qbb6hhry48dp1w6"))))
+         "1c02gdp1j18xny9jd33fp0w57qqi7g66zwmaykv2dhcks96f5mxr"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
@@ -5674,9 +5674,8 @@  as a Python package.")
            ;; Allow using recent dependencies.
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* "setup.py"
-               (("httpcore==0.3.0") "httpcore")
                (("pytest==5.2.1") "pytest")
-               (("multidict==5.0.0") "multidict")
+               (("multidict>=5.0,<6.0") "multidict")
                (("httpx==0\\.15\\.4") "httpx"))
              #t))
          (replace 'check
@@ -5702,14 +5701,15 @@  as a Python package.")
        ("python-pytest-benchmark" ,python-pytest-benchmark)
        ("python-pytest-sanic" ,python-pytest-sanic)
        ("python-pytest-sugar" ,python-pytest-sugar)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
        ("python-urllib3" ,python-urllib3)
        ("python-uvicorn" ,python-uvicorn)))
     (home-page
-     "https://github.com/huge-success/sanic/")
+     "https://github.com/sanic-org/sanic/")
     (synopsis
-     "Async Python 3.6+ web server/framework")
+     "Async Python web server/framework")
     (description
-     "Sanic is a Python 3.6+ web server and web framework
+     "Sanic is a Python web server and web framework
 that's written to go fast.  It allows the usage of the
 @code{async/await} syntax added in Python 3.5, which makes
 your code non-blocking and speedy.")
-- 
2.25.1