diff mbox series

[bug#46919,PATCHES] Update python-asyncssh and dependencies

Message ID 20210304140951.GA2963@zpidnp36
State Accepted
Headers show
Series [bug#46919,PATCHES] Update python-asyncssh and dependencies | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Lars-Dominik Braun March 4, 2021, 2:09 p.m. UTC
Hi,

attached patches update python-asyncssh and its dependency python-gssapi. I’m
also dropping python-shouldbe, since it has no dependents after applying these
patches and is unmaintained upstream.

Cheers,
Lars

Comments

Lars-Dominik Braun March 10, 2021, 11:32 a.m. UTC | #1
Pushed as 714465ec7c1d3c40e710e95ec5bd6651311827d6.
diff mbox series

Patch

From 8f6ba6b314222244cec40504c7b108de9a2b918e Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Thu, 4 Mar 2021 12:00:47 +0100
Subject: [PATCH 3/3] gnu: python-shouldbe: Remove.

Unmaintained upstream and its only dependent (python-gssapi) dropped it.

* gnu/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch: Remove.
* gnu/local.mk: Drop patch file.
* gnu/packages/python-xyz.scm (python-shouldbe): Remove.
---
 gnu/local.mk                                  |  1 -
 .../python-shouldbe-0.1.2-cpy3.8.patch        | 82 -------------------
 gnu/packages/python-xyz.scm                   | 23 ------
 3 files changed, 106 deletions(-)
 delete mode 100644 gnu/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 3557d9f429..815648d033 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1554,7 +1554,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/python2-pygobject-2-deprecation.patch	\
   %D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch	\
   %D%/packages/patches/python-robotframework-source-date-epoch.patch \
-  %D%/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch	\
   %D%/packages/patches/python2-subprocess32-disable-input-test.patch	\
   %D%/packages/patches/python-unittest2-python3-compat.patch	\
   %D%/packages/patches/python-unittest2-remove-argparse.patch	\
diff --git a/gnu/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch b/gnu/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch
deleted file mode 100644
index f3b56e42d6..0000000000
--- a/gnu/packages/patches/python-shouldbe-0.1.2-cpy3.8.patch
+++ /dev/null
@@ -1,82 +0,0 @@ 
-Fix compatibility with Python 3.8.
-
-Upstream issue: https://github.com/DirectXMan12/should_be/pull/5
-
-diff -x '*.pyc' -Naur shouldbe-0.1.2/should_be/core.py shouldbe-0.1.2.patched/should_be/core.py
---- shouldbe-0.1.2/should_be/core.py	2019-03-06 07:38:22.000000000 +0100
-+++ shouldbe-0.1.2.patched/should_be/core.py	2020-05-18 08:44:24.214664704 +0200
-@@ -103,7 +103,7 @@
-     return resf
- 
- 
--def buildCode(baseCode, argcount=None, kwonlyargcount=None,
-+def buildCode(baseCode, argcount=None, posonlyargcount=None, kwonlyargcount=None,
-               nlocals=None, stacksize=None, flags=None,
-               code=None, consts=None, names=None,
-               varnames=None, filename=None, name=None,
-@@ -121,6 +121,24 @@
-                         nlocals or baseCode.co_nlocals,
-                         stacksize or baseCode.co_stacksize,
-                         flags or baseCode.co_flags,
-+                        code or baseCode.co_code,
-+                        consts or baseCode.co_consts,
-+                        names or baseCode.co_names,
-+                        varnames or baseCode.co_varnames,
-+                        filename or baseCode.co_filename,
-+                        name or baseCode.co_name,
-+                        firstlineno or baseCode.co_firstlineno,
-+                        lnotab or baseCode.co_lnotab,
-+                        freevars or baseCode.co_freevars,
-+                        cellvars or baseCode.co_cellvars)
-+    elif hasattr(baseCode, 'co_posonlyargcount'):
-+        # Python 3.8
-+        resc = CodeType(argcount or baseCode.co_argcount,
-+                        posonlyargcount or baseCode.co_posonlyargcount,
-+                        kwonlyargcount or baseCode.co_kwonlyargcount,
-+                        nlocals or baseCode.co_nlocals,
-+                        stacksize or baseCode.co_stacksize,
-+                        flags or baseCode.co_flags,
-                         code or baseCode.co_code,
-                         consts or baseCode.co_consts,
-                         names or baseCode.co_names,
-diff -x '*.pyc' -Naur shouldbe-0.1.2/should_be/tests/test_container_mixin.py shouldbe-0.1.2.patched/should_be/tests/test_container_mixin.py
---- shouldbe-0.1.2/should_be/tests/test_container_mixin.py	2019-03-01 06:38:16.000000000 +0100
-+++ shouldbe-0.1.2.patched/should_be/tests/test_container_mixin.py	2020-05-18 09:00:51.372531064 +0200
-@@ -7,31 +7,31 @@
-         self.lst = [1, 2, 3]
- 
-     def test_should_include_iter(self):
--        err_msg = (r'[a-zA-Z0-9.]+ should have included \[.+?\]'
-+        err_msg = (r'[a-zA-Z0-9.()]+ should have included \[.+?\]'
-                    r', but did not have items .+')
--        self.assertRaisesRegexp(AssertionError, err_msg,
-+        self.assertRaisesRegex(AssertionError, err_msg,
-                                 self.lst.should_include, [4])
- 
-         self.lst.should_include([1, 2, 3])
- 
-     def test_should_include_item(self):
--        err_msg = (r'[a-zA-Z0-9.]+ should have included .+?'
-+        err_msg = (r'[a-zA-Z0-9.()]+ should have included .+?'
-                    r', but did not')
--        self.assertRaisesRegexp(AssertionError, err_msg,
-+        self.assertRaisesRegex(AssertionError, err_msg,
-                                 self.lst.should_include, 4)
- 
-         self.lst.should_include(3)
- 
-     def test_shouldnt_include_iter(self):
-         err_msg = 'should not have included'
--        self.assertRaisesRegexp(AssertionError, err_msg,
-+        self.assertRaisesRegex(AssertionError, err_msg,
-                                 self.lst.shouldnt_include, [2, 3])
- 
-         self.lst.shouldnt_include([4, 5])
- 
-     def test_shouldnt_include_item(self):
-         err_msg = 'should not have included'
--        self.assertRaisesRegexp(AssertionError, err_msg,
-+        self.assertRaisesRegex(AssertionError, err_msg,
-                                 self.lst.shouldnt_include, 3)
- 
-         self.lst.shouldnt_include(4)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 515d644e9e..0b981be7c1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21548,29 +21548,6 @@  and cuts down boilerplate code when testing libraries for asyncio.")
     (description "This project allows Python code to extend built-in types.")
     (license (list license:gpl3+ license:expat))))
 
-(define-public python-shouldbe
-  (package
-    (name "python-shouldbe")
-    (version "0.1.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "shouldbe" version))
-       (sha256
-        (base32
-         "16zbvjxf71dl4yfbgcr6idyim3mdrfvix1dv8b95p0s9z07372pj"))
-       (patches (search-patches "python-shouldbe-0.1.2-cpy3.8.patch"))))
-    (build-system python-build-system)
-    (propagated-inputs
-      `(("python-forbiddenfruit" ,python-forbiddenfruit)))
-    (native-inputs
-     `(("python-nose" ,python-nose)))
-    (home-page "https://github.com/directxman12/should_be")
-    (synopsis "Python Assertion Helpers inspired by Shouldly")
-    (description
-     "Python Assertion Helpers inspired by Shouldly.")
-    (license license:isc)))
-
 (define-public python-k5test
   (package
     (name "python-k5test")
-- 
2.25.1