diff mbox series

[bug#46842] gnu: gnuradio: Updated to 3.9.0.0.

Message ID 20210301035622.9778-1-jpsimas@gmail.com
State Accepted
Headers show
Series [bug#46842] gnu: gnuradio: Updated to 3.9.0.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

João March 1, 2021, 3:56 a.m. UTC
---
 gnu/packages/radio.scm | 14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)

Comments

Ludovic Courtès March 1, 2021, 3:59 p.m. UTC | #1
Hi,

João <jpsimas@gmail.com> skribis:

>         (uri (string-append "https://www.gnuradio.org/releases/gnuradio/"
>                             "gnuradio-" version ".tar.xz"))
>         (sha256
> -        (base32 "0aw55gf5549b0fz2qdi7vplcmaf92bj34h40s34b2ycnqasv900r"))
> -       (modules '((guix build utils)))
> -       (snippet
> -        '(begin
> -           ;; Delete bundled volk to use the shared one.
> -           (delete-file-recursively "volk")
> -           #t))))

Could you confirm there’s no longer a bundled copy of volk or anything
else?

>         #:configure-flags
>         '("-DENABLE_INTERNAL_VOLK=OFF")
> +       #:tests? #false ;disable tests (some tests fail. gnuradio issue #3871)

Could you (1) write the full URL of the issue, and (2) skip only
selected tests instead of disabling tests wholesale?

Bonus points if you write a ChangeLog-style commit log.  :-)

Thanks in advance!

Ludo’.
Ludovic Courtès March 11, 2021, 10:12 p.m. UTC | #2
Ping!  :-)

Ludovic Courtès <ludo@gnu.org> skribis:

> Hi,
>
> João <jpsimas@gmail.com> skribis:
>
>>         (uri (string-append "https://www.gnuradio.org/releases/gnuradio/"
>>                             "gnuradio-" version ".tar.xz"))
>>         (sha256
>> -        (base32 "0aw55gf5549b0fz2qdi7vplcmaf92bj34h40s34b2ycnqasv900r"))
>> -       (modules '((guix build utils)))
>> -       (snippet
>> -        '(begin
>> -           ;; Delete bundled volk to use the shared one.
>> -           (delete-file-recursively "volk")
>> -           #t))))
>
> Could you confirm there’s no longer a bundled copy of volk or anything
> else?
>
>>         #:configure-flags
>>         '("-DENABLE_INTERNAL_VOLK=OFF")
>> +       #:tests? #false ;disable tests (some tests fail. gnuradio issue #3871)
>
> Could you (1) write the full URL of the issue, and (2) skip only
> selected tests instead of disabling tests wholesale?
>
> Bonus points if you write a ChangeLog-style commit log.  :-)
>
> Thanks in advance!
>
> Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index af6d852a98..0aa8599ca4 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -279,32 +279,27 @@  used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
 (define-public gnuradio
   (package
     (name "gnuradio")
-    (version "3.8.0.0")
+    (version "3.9.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.gnuradio.org/releases/gnuradio/"
                            "gnuradio-" version ".tar.xz"))
        (sha256
-        (base32 "0aw55gf5549b0fz2qdi7vplcmaf92bj34h40s34b2ycnqasv900r"))
-       (modules '((guix build utils)))
-       (snippet
-        '(begin
-           ;; Delete bundled volk to use the shared one.
-           (delete-file-recursively "volk")
-           #t))))
+	(base32 "1jvm9xd0l2pz1fww4zii6hl7ccnvy256nrf70ljb594n7j9j49ha"))
+       (modules '((guix build utils)))))
     (build-system cmake-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
        ("ghostscript" ,ghostscript)
        ("orc" ,orc)
        ("pkg-config" ,pkg-config)
+       ("pybind11" ,pybind11)
        ("python-cheetah" ,python-cheetah)
        ("python-mako" ,python-mako)
        ("python-pyzmq" ,python-pyzmq)
        ("python-scipy" ,python-scipy)
        ("python-sphinx" ,python-sphinx)
-       ("swig" ,swig)
        ("texlive" ,(texlive-union (list texlive-amsfonts
                                         texlive-latex-amsmath
                                         ;; TODO: Add newunicodechar.
@@ -349,6 +344,7 @@  used by RDS Spy, and audio files containing @dfn{multiplex} signals (MPX).")
                            (guix build python-build-system))
        #:configure-flags
        '("-DENABLE_INTERNAL_VOLK=OFF")
+       #:tests? #false ;disable tests (some tests fail. gnuradio issue #3871)
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'fix-paths