diff mbox series

[bug#46823,2/3] gnu: Add python-listparser.

Message ID 20210227223631.18891-2-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#46823,1/3] gnu: Add python-readability. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Feb. 27, 2021, 10:36 p.m. UTC
* gnu/packages/python-xyz.scm (python-listparser): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1ff51d1b2c..569a49ef36 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23932,6 +23932,26 @@  and frame grabber interface.")
                ;; Yet another variant of the X/MIT license.
                "https://github.com/python-pillow/Sane/blob/master/COPYING"))))
 
+(define-public python-listparser
+  (package
+    (name "python-listparser")
+    (version "0.18")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "listparser" version))
+        (sha256
+          (base32
+            "0hdqs1mmayw1r8yla43hgb4d9y3zqs5483vgf8j9ygczkd2wrq2b"))))
+    (build-system python-build-system)
+    (home-page
+      "https://github.com/kurtmckee/listparser")
+    (synopsis
+      "Parse subscription lists in Python")
+    (description
+      "Parse OPML, FOAF, and iGoogle subscription lists in Python.")
+    (license license:expat)))
+
 (define-public python-screenkey
   (package
     (name "python-screenkey")