diff mbox series

[bug#46816,Added,capstone,4.] gnu: capstone: Update to 4.0.2.

Message ID 20210227172545.8032-1-gheber@hdfgroup.org
State Accepted
Headers show
Series [bug#46816,Added,capstone,4.] gnu: capstone: Update to 4.0.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Gerd Heber Feb. 27, 2021, 5:25 p.m. UTC
---
 gnu/packages/engineering.scm | 23 ++++++++++++-----------
 1 file changed, 12 insertions(+), 11 deletions(-)

Comments

Gerd Heber Feb. 28, 2021, 3:49 a.m. UTC | #1
A tool dependence, python-capstone, fails to build with capstone 4.
python2-capstone builds fine, but not python-capstone.
Please close this report. I'll have to try something else.

G.
Andreas Enge Feb. 28, 2021, 10:18 a.m. UTC | #2
Hello,

one can close the bug by sending a message to
   46816-done@debbugs.gnu.org

Done for now,

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 4987377840..367e139aff 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1501,23 +1501,24 @@  bindings for Python, Java, OCaml and more.")
    (version "4.0.2")
    (source
     (origin
-     (method url-fetch)
-     (uri (string-append "https://github.com/aquynh/capstone"
-                         "/archive/" version ".tar.gz"))
+      (method git-fetch)
+      (uri (git-reference
+             (url "https://github.com/aquynh/capstone")
+             (commit version)))
+     (file-name (git-file-name name version))
      (sha256
       (base32
-       "0sjjbqps48az4map0kmai7j7dak3gy0xcq0sgx8fg09g0acdg0bw"))))
+       "0y5g74yjyliciawpn16zhdwya7bd3d7b1cccpcccc2wg8vni1k2w"))))
    (build-system cmake-build-system)
    (arguments
-    `(#:build-type "Release"
-      #:tests? #t))
+    `(#:build-type "Release"))
    (home-page "https://www.capstone-engine.org")
-   (synopsis "Lightweight multi-platform, multi-architecture disassembly framework")
+   (synopsis "Lightweight multi-architecture disassembly framework")
    (description
-    "Capstone is a lightweight multi-platform, multi-architecture disassembly
-framework. Capstone can disassemble machine code for many supported
-architectures such as x86, x86_64, arm, arm64, mips, ppc, sparc, sysz and
-xcore. It provides bindings for Python, Java, OCaml and more.")
+    "Capstone is a lightweight multi-architecture disassembly framework.
+Capstone can disassemble machine code for many supported architectures such as
+x86, x86_64, arm, arm64, mips, ppc, sparc, sysz and xcore.  It provides
+bindings for Python, Java, OCaml and more.")
    (license license:bsd-3)))
 
 ;; FIXME: This package has a timestamp embedded in