diff mbox series

[bug#46741] gnu: Return appropriate defconfig for ppc64 (non-LE)

Message ID 20210224030312.458470-1-contact@carldong.me
State Accepted
Headers show
Series [bug#46741] gnu: Return appropriate defconfig for ppc64 (non-LE) | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Carl Dong Feb. 24, 2021, 3:03 a.m. UTC
* gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
---
 gnu/packages/linux.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Efraim Flashner Feb. 24, 2021, 8:17 a.m. UTC | #1
On Tue, Feb 23, 2021 at 10:03:12PM -0500, Carl Dong wrote:
> * gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
> ---
>  gnu/packages/linux.scm | 1 +
>  1 file changed, 1 insertion(+)
> 
> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> index c87c5ffb09..30cbebf849 100644
> --- a/gnu/packages/linux.scm
> +++ b/gnu/packages/linux.scm
> @@ -181,6 +181,7 @@
>  defconfig.  Return the appropriate make target if applicable, otherwise return
>  \"defconfig\"."
>    (cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
> +        ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
>          ((string-prefix? "powerpc64le-" system) "ppc64_defconfig")

would it make more sense to change it to "powerpc64" or "powerpc(64)?-"?

>          (else "defconfig")))
>  
> -- 
> 2.30.1
> 
> 
> 
>
Carl Dong Feb. 24, 2021, 8:30 p.m. UTC | #2
Hmmm does string-prefix? accept regex? And if so perhaps it should be "powerpc64(le)?-“?

Carl Dong
contact@carldong.me
"I fight for the users"

> On Feb 24, 2021, at 3:17 AM, Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> On Tue, Feb 23, 2021 at 10:03:12PM -0500, Carl Dong wrote:
>> * gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
>> ---
>> gnu/packages/linux.scm | 1 +
>> 1 file changed, 1 insertion(+)
>> 
>> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
>> index c87c5ffb09..30cbebf849 100644
>> --- a/gnu/packages/linux.scm
>> +++ b/gnu/packages/linux.scm
>> @@ -181,6 +181,7 @@
>> defconfig.  Return the appropriate make target if applicable, otherwise return
>> \"defconfig\"."
>>   (cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
>> +        ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
>>         ((string-prefix? "powerpc64le-" system) "ppc64_defconfig")
> 
> would it make more sense to change it to "powerpc64" or "powerpc(64)?-"?
> 
>>         (else "defconfig")))
>> 
>> --
>> 2.30.1
>> 
>> 
>> 
>> 
> 
> --
> Efraim Flashner   <efraim@flashner.co.il>   אפרים פלשנר
> GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
> Confidentiality cannot be guaranteed on emails sent or received unencrypted
Efraim Flashner Feb. 25, 2021, 6:09 a.m. UTC | #3
On Wed, Feb 24, 2021 at 03:30:00PM -0500, Carl Dong wrote:
> Hmmm does string-prefix? accept regex? And if so perhaps it should be "powerpc64(le)?-“?

Definitely what I meant to write

> 
> Carl Dong
> contact@carldong.me
> "I fight for the users"
> 
> > On Feb 24, 2021, at 3:17 AM, Efraim Flashner <efraim@flashner.co.il> wrote:
> > 
> > On Tue, Feb 23, 2021 at 10:03:12PM -0500, Carl Dong wrote:
> >> * gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
> >> ---
> >> gnu/packages/linux.scm | 1 +
> >> 1 file changed, 1 insertion(+)
> >> 
> >> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> >> index c87c5ffb09..30cbebf849 100644
> >> --- a/gnu/packages/linux.scm
> >> +++ b/gnu/packages/linux.scm
> >> @@ -181,6 +181,7 @@
> >> defconfig.  Return the appropriate make target if applicable, otherwise return
> >> \"defconfig\"."
> >>   (cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
> >> +        ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
> >>         ((string-prefix? "powerpc64le-" system) "ppc64_defconfig")
> > 
> > would it make more sense to change it to "powerpc64" or "powerpc(64)?-"?
> > 
> >>         (else "defconfig")))
> >> 
> >> --
> >> 2.30.1
> >> 
> >> 
>
Efraim Flashner Feb. 25, 2021, 10:22 a.m. UTC | #4
I did some quick testing from the guile repl and it looks like it
doesn't take a regex. I have no preference between two entries for
'powerpc64-' and 'powerpc64le-' vs 'powerpc64'.

On Wed, Feb 24, 2021 at 03:30:00PM -0500, Carl Dong wrote:
> Hmmm does string-prefix? accept regex? And if so perhaps it should be "powerpc64(le)?-“?
> 
> Carl Dong
> contact@carldong.me
> "I fight for the users"
> 
> > On Feb 24, 2021, at 3:17 AM, Efraim Flashner <efraim@flashner.co.il> wrote:
> > 
> > On Tue, Feb 23, 2021 at 10:03:12PM -0500, Carl Dong wrote:
> >> * gnu/packages/linux.scm (system->defconfig): Add "powerpc64-" prefix.
> >> ---
> >> gnu/packages/linux.scm | 1 +
> >> 1 file changed, 1 insertion(+)
> >> 
> >> diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
> >> index c87c5ffb09..30cbebf849 100644
> >> --- a/gnu/packages/linux.scm
> >> +++ b/gnu/packages/linux.scm
> >> @@ -181,6 +181,7 @@
> >> defconfig.  Return the appropriate make target if applicable, otherwise return
> >> \"defconfig\"."
> >>   (cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
> >> +        ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
> >>         ((string-prefix? "powerpc64le-" system) "ppc64_defconfig")
> > 
> > would it make more sense to change it to "powerpc64" or "powerpc(64)?-"?
> > 
> >>         (else "defconfig")))
> >> 
> >> --
> >> 2.30.1
> >> 
> >> 
> >> 
> >> 
> > 
> > --
> > Efraim Flashner   <efraim@flashner.co.il>   אפרים פלשנר
> > GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
> > Confidentiality cannot be guaranteed on emails sent or received unencrypted
>
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c87c5ffb09..30cbebf849 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -181,6 +181,7 @@ 
 defconfig.  Return the appropriate make target if applicable, otherwise return
 \"defconfig\"."
   (cond ((string-prefix? "powerpc-" system) "pmac32_defconfig")
+        ((string-prefix? "powerpc64-" system) "ppc64_defconfig")
         ((string-prefix? "powerpc64le-" system) "ppc64_defconfig")
         (else "defconfig")))