diff mbox series

[bug#46698] Added syscall_intercept.

Message ID 20210221224210.6557-1-gheber@hdfgroup.org
State Accepted
Headers show
Series [bug#46698] Added syscall_intercept. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Gerd Heber Feb. 21, 2021, 10:42 p.m. UTC
---
 gnu/packages/engineering.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Nicolas Goaziou March 13, 2021, 2:14 p.m. UTC | #1
Hello,

Gerd Heber <gerd.heber@gmail.com> writes:

> +(define-public syscall_intercept

Thank you.

I added a comment explaining why we are using a specific untagged
commit, and another one explaining there is currently a test failing.

I also added a copyright line for you and a proper commit message.

Note that I renamed the package as syscall-intercept, as we usually do
not use underscore in package names.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 034dabc3f9..626338b868 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2996,3 +2996,35 @@  and drilling of PCBs.  It takes Gerber files as input and outputs G-code files
 for the milling of PCBs.  It also includes an autoleveller for the automatic
 dynamic calibration of the milling depth.")
      (license license:gpl3+)))
+
+(define-public syscall_intercept
+  (package
+   (name "syscall_intercept")
+   (version "0.1.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+      (git-reference
+       (url "https://github.com/pmem/syscall_intercept/")
+       (commit "304404581c57d43478438d175099d20260bae74e")))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32
+       "17sw78xp5wjzv25adpbq3khl8fi0avj7bgpi57q3jnvl3c68xy5z"))))
+   (inputs
+    `(("capstone" ,capstone)))
+   (native-inputs
+     `(("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+   (build-system cmake-build-system)
+   (arguments
+    `(#:build-type "Release"
+      #:tests? #f))
+   (synopsis "The system call intercepting library")
+   (description "The system call intercepting library provides a low-level
+interface for hooking Linux system calls in user space. This is achieved by
+hotpatching the machine code of the standard C library in the memory of a
+process.")
+   (home-page "https://github.com/pmem/syscall_intercept")
+   (license license:bsd-2)))