diff mbox series

[bug#46693] Added HDF5 1.12.0.

Message ID 20210221185751.10341-1-gheber@hdfgroup.org
State Accepted
Headers show
Series [bug#46693] Added HDF5 1.12.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Gerd Heber Feb. 21, 2021, 6:57 p.m. UTC
---
 gnu/packages/maths.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Leo Famulari Feb. 21, 2021, 9:04 p.m. UTC | #1
On Sun, Feb 21, 2021 at 12:57:51PM -0600, Gerd Heber wrote:
> ---
>  gnu/packages/maths.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> 
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 42f3881bbc..a40e4677af 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm
> @@ -1219,6 +1219,25 @@ extremely large and complex data collections.")
>          (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
>         (patches (search-patches "hdf5-config-date.patch"))))))
>  
> +(define-public hdf5-1.12

Thanks! I wrote the commit message, added your name to the list of
authors, and pushed as f601cdc6981888f55882c942dab413cb783caecc
diff mbox series

Patch

diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 42f3881bbc..a40e4677af 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1219,6 +1219,25 @@  extremely large and complex data collections.")
         (base32 "0pm5xxry55i0h7wmvc7svzdaa90rnk7h78rrjmnlkz2ygsn8y082"))
        (patches (search-patches "hdf5-config-date.patch"))))))
 
+(define-public hdf5-1.12
+  (package/inherit hdf5-1.8
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+                                 "hdf5-" (version-major+minor version)
+                                 "/hdf5-" version "/src/hdf5-"
+                                 version ".tar.bz2")
+                  (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+                                 "current"
+                                 (apply string-append
+                                        (take (string-split version #\.) 2))
+                                 "/src/hdf5-" version ".tar.bz2")))
+       (sha256
+        (base32 "0qazfslkqbmzg495jafpvqp0khws3jkxa0z7rph9qvhacil6544p"))
+       (patches (search-patches "hdf5-config-date.patch"))))))
+
 (define-public hdf5
   ;; Default version of HDF5.
   hdf5-1.10)