diff mbox series

[bug#46645,2/3] gnu: Add ghc-wordexp.

Message ID 20210219200427.105200-2-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46643,1/3] gnu: ghc-protolude: Update to 0.3.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 19, 2021, 8:04 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-wordexp): New variable.
---

I am not sure what license should be used for this package.

 gnu/packages/haskell-xyz.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f1709e342a..a48a100441 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15169,6 +15169,30 @@  modernized interface.")
     (description "Word8 library to be used with @code{Data.ByteString}.")
     (license license:bsd-3)))
 
+(define-public ghc-wordexp
+  (package
+    (name "ghc-wordexp")
+    (version "0.2.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/wordexp/wordexp-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1mbcrq89jz0dcibw66w0jdy4f4bfpx4zwjfs98rm3jjgdikwdzb4"))))
+    (build-system haskell-build-system)
+    (native-inputs `(("ghc-c2hs" ,ghc-c2hs)))
+    (inputs
+     `(("ghc-semigroups" ,ghc-semigroups)))
+    (home-page "https://hackage.haskell.org/package/wordexp")
+    (synopsis "wordexp wrapper library for Haskell")
+    (description "wordexp(3) wrapper library for Haskell to perform word
+expansion like a posix-shell.")
+    (license license:expat)))
+
 (define-public ghc-x11
   (package
     (name "ghc-x11")