diff mbox series

[bug#46643,1/3] gnu: ghc-protolude: Update to 0.3.0.

Message ID 20210219200427.105200-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46643,1/3] gnu: ghc-protolude: Update to 0.3.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 19, 2021, 8:04 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-protolude): Update to 0.3.0.
---
 gnu/packages/haskell-xyz.scm | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

Comments

Léo Le Bouter Feb. 24, 2021, 2:27 p.m. UTC | #1
Pushed all patches in a1386815503036773a1092554f36d45dd9361efe.

It seems the licenses for ghc-wordexp and greenclip is BSD-3-Clause
from <https://hackage.haskell.org/package/wordexp> and <
https://hackage.haskell.org/package/greenclip>.

Also, your upgrade of ghc-protolude broke the purescript build which
depends on ghc-protolude<0.2.4 so I created a secondary ghc-protolude-
0.2 package that purescript now depends on.

Think about running "$ guix refresh -l <package>" if you modify any
package to check for all its dependents and then try to build all the
dependents see if they don't break and if they do break please fix
them. That's what I did here.

I also fixed lint errors on ghc-wordexp. Think about running "$ guix
lint <package>" on any package you are adding or altering before
submitting.

Thank you!
Simon Tournier Feb. 24, 2021, 3:40 p.m. UTC | #2
Hi Léo,

On Wed, 24 Feb 2021 at 15:28, Léo Le Bouter via Guix-patches via
<guix-patches@gnu.org> wrote:

> Also, your upgrade of ghc-protolude broke the purescript build which
> depends on ghc-protolude<0.2.4 so I created a secondary ghc-protolude-
> 0.2 package that purescript now depends on.

Usually, IIUC, the Haskell packages follows one LTS.  And there are
updated in one go to avoid the Cabal Hell.  Well, the current
%default-lts-version is 14.27 which has protolude at 0.2.3 [1].  LTS
14.27 supports GHC 8.6 which is the default current ghc in Guix.
Using LTS 17.4 seems a bad idea since it supports GHC 8.10 which is
not yet included in Guix.  Therefore, ghc-protolude should not be
updated and ghc-protolude-0.2 should not be added, neither.  Or I am
missing something.  Except corner cases, please keep the Haskell
packages consistent with one LTS.  The linter should warn about this
but it does not; I have not investigated why.

If greenclip cannot be built with ghc-protolude@0.2.3, please let the
"define-public ghc-protolude" at 0.2.3 and instead define
ghc-protolude-0.3.  As it is done for ghc-atomic-write or
ghc-generic-random or ghc-prettyprinter or ghc-repline.

Thanks,
simon

1: <https://www.stackage.org/lts-14.27/package/protolude-0.2.3>
Léo Le Bouter Feb. 24, 2021, 5 p.m. UTC | #3
On Wed, 2021-02-24 at 16:40 +0100, zimoun wrote:
> Hi Léo,

Hello! :-)

> If greenclip cannot be built with ghc-protolude@0.2.3, please let the
> "define-public ghc-protolude" at 0.2.3 and instead define
> ghc-protolude-0.3.  As it is done for ghc-atomic-write or
> ghc-generic-random or ghc-prettyprinter or ghc-repline.

I see, pushed 6bea71afac702fcab9fb420daa30aec95652e1a0 to hopefully fix
these concerns. Will keep in mind!

What about ghc-wordexp? Is the version on LTS channel? I couldnt find
much about that online (not very at ease with Stackage).

Thank you!
Stefan Reichör Feb. 24, 2021, 7:14 p.m. UTC | #4
Hi Léo, Hi Simon,

thank you both for your kind help.

I already enjoy using Guix and I hope to master it more and more in the future!

Stefan.

> On Wed, 2021-02-24 at 16:40 +0100, zimoun wrote:
>> Hi Léo,
>
> Hello! :-)
>
>> If greenclip cannot be built with ghc-protolude@0.2.3, please let the
>> "define-public ghc-protolude" at 0.2.3 and instead define
>> ghc-protolude-0.3.  As it is done for ghc-atomic-write or
>> ghc-generic-random or ghc-prettyprinter or ghc-repline.
>
> I see, pushed 6bea71afac702fcab9fb420daa30aec95652e1a0 to hopefully fix
> these concerns. Will keep in mind!
>
> What about ghc-wordexp? Is the version on LTS channel? I couldnt find
> much about that online (not very at ease with Stackage).
>
> Thank you!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d6c50ade71..f1709e342a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
 ;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10535,7 +10536,7 @@  the ideal templating system.")
 (define-public ghc-protolude
   (package
     (name "ghc-protolude")
-    (version "0.2.3")
+    (version "0.3.0")
     (source
      (origin
        (method url-fetch)
@@ -10545,7 +10546,7 @@  the ideal templating system.")
              ".tar.gz"))
        (sha256
         (base32
-         "0zzkyxz0vmcbncpid7gp72fpjj0fla3gqhlfkij5c5lg12skjgfj"))))
+         "1b6wprbwfdjyvds2bm6na0fbqgzdkj5ikkk33whbkyh3krd3i0s0"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-async" ,ghc-async)