diff mbox series

[bug#46616] gnu: Add python-tldr.

Message ID 20210218140620.15816-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#46616] gnu: Add python-tldr. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Feb. 18, 2021, 2:06 p.m. UTC
* gnu/packages/python-xyz.scm (python-tldr): New variable.
---
 gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

Comments

Vinicius Monego May 23, 2021, 9:15 p.m. UTC | #1
Hi,

Em qui, 2021-02-18 às 15:06 +0100, Tanguy Le Carrour escreveu:
> * gnu/packages/python-xyz.scm (python-tldr): New variable.
> ---
>  gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-

[...]

> +(define-public python-tldr
> +  (package
> +    (name "python-tldr")

I noticed that this program is a command line tool. It should be named
'tldr' only and be moved to another file. Perhaps to man.scm?

> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (pypi-uri "tldr" version))
> +        (sha256
> +         (base32
> +          "00h43xjrzrayy1gysvmql5kfabk2d8xraih68d41616brdvb1xvf"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     `(("python-pytest" ,python-pytest)
> +       ("python-pytest-runner" ,python-pytest-runner)))

The tests for this one are not distributed in the PyPI release. Could
you source from the homepage instead?

There is one test that tries to open a network connection, it will have
to be skipped.

> +    (propagated-inputs
> +     `(("python-argcomplete" ,python-argcomplete)
> +       ("python-colorama" ,python-colorama)
> +       ("python-termcolor" ,python-termcolor)))

If it is only a command line tool, inputs should be normal inputs here.

> +    (description "This package provides the `tldr' command allowing
> users
> +to view `tldr' pages from a shell.  The `tldr' pages are a community
> effort
> +to simplify the man pages with practical examples.")

The linter made this complaint for the description: "use @code or
similar ornament instead of quotes".

LGTM otherwise.

Could you make these changes and send a v2 with version 1.2.1?

Vinicius
Tanguy LE CARROUR June 6, 2021, 2:14 p.m. UTC | #2
Hi Vinicius,

Thanks for reviewing this patch, and sorry for the late answer!


Excerpts from Vinicius Monego's message of May 23, 2021 11:15 pm:
> Em qui, 2021-02-18 às 15:06 +0100, Tanguy Le Carrour escreveu:
>> * gnu/packages/python-xyz.scm (python-tldr): New variable.
>> ---
>>  gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
> 
> [...]
> 
>> +(define-public python-tldr
>> +  (package
>> +    (name "python-tldr")
> 
> I noticed that this program is a command line tool. It should be named
> 'tldr' only and be moved to another file. Perhaps to man.scm?

Your suggestions make sense, but there's another `tldr` client.
Namely `ghc-tldr`. It's defined in `gnu/packages/haskell-xyz.scm`.
If it's okay with you, I'll leave `python-tldr` in `gnu/packages/python-xyz.scm`.


>> +    (source
>> +      (origin
>> +        (method url-fetch)
>> +        (uri (pypi-uri "tldr" version))
>> +        (sha256
>> +         (base32
>> +          "00h43xjrzrayy1gysvmql5kfabk2d8xraih68d41616brdvb1xvf"))))
>> +    (build-system python-build-system)
>> +    (native-inputs
>> +     `(("python-pytest" ,python-pytest)
>> +       ("python-pytest-runner" ,python-pytest-runner)))
> 
> The tests for this one are not distributed in the PyPI release. Could
> you source from the homepage instead?
> 
> There is one test that tries to open a network connection, it will have
> to be skipped.

Done.


> 
>> +    (propagated-inputs
>> +     `(("python-argcomplete" ,python-argcomplete)
>> +       ("python-colorama" ,python-colorama)
>> +       ("python-termcolor" ,python-termcolor)))
> 
> If it is only a command line tool, inputs should be normal inputs here.

Done.


>> +    (description "This package provides the `tldr' command allowing
>> users
>> +to view `tldr' pages from a shell.  The `tldr' pages are a community
>> effort
>> +to simplify the man pages with practical examples.")
> 
> The linter made this complaint for the description: "use @code or
> similar ornament instead of quotes".

Done.


The new patch is following in another email…

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a504bb521b..b315d5f634 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -66,7 +66,7 @@ 
 ;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
 ;;; Copyright © 2019, 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
-;;; Copyright © 2019, 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2019, 2020, 2021 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Riku Viitanen <riku.viitanen@protonmail.com>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -19267,6 +19267,32 @@  Public Suffix List's private domains as well.")
 (define-public python2-tldextract
   (package-with-python2 python-tldextract))
 
+(define-public python-tldr
+  (package
+    (name "python-tldr")
+    (version "1.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "tldr" version))
+        (sha256
+         (base32
+          "00h43xjrzrayy1gysvmql5kfabk2d8xraih68d41616brdvb1xvf"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (propagated-inputs
+     `(("python-argcomplete" ,python-argcomplete)
+       ("python-colorama" ,python-colorama)
+       ("python-termcolor" ,python-termcolor)))
+    (home-page "https://github.com/tldr-pages/tldr-python-client")
+    (synopsis "Python command-line client for tldr pages")
+    (description "This package provides the `tldr' command allowing users
+to view `tldr' pages from a shell.  The `tldr' pages are a community effort
+to simplify the man pages with practical examples.")
+    (license license:expat))) ; MIT license
+
 (define-public python-nodeenv
   (package
     (name "python-nodeenv")