diff mbox series

[bug#46541] gnu: Add ttyload.

Message ID 20210215192825.47358-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46541] gnu: Add ttyload. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 15, 2021, 7:28 p.m. UTC
* gnu/packages/admin.scm (ttyload): New variable.
---
 gnu/packages/admin.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

宋文武 Feb. 16, 2021, 8:32 a.m. UTC | #1
Hello!

Stefan Reichör <stefan@xsteve.at> writes:
> [...]
> * gnu/packages/admin.scm (ttyload): New variable.
> +      (home-page "https://www.daveltd.com/src/util/ttyload/")
> +      (synopsis "Console based color-coded graphs of CPU load average")
> +      (description
> +       "Show graphs for 1 minute, 5 minute, 15 minute load averages on the console.")
Better limit lines under 80 characters.

> +      (license license:expat))))
It's a modified "ISC License", I think it should be (fsf-free "file://LICENSE").
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 77386d6033..f1b398c39a 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -36,6 +36,7 @@ 
 ;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;; Copyright © 2020 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -527,6 +528,40 @@  or via the @code{facter} Ruby library.")
     (home-page "https://github.com/puppetlabs/facter-ng")
     (license license:expat)))
 
+(define-public ttyload
+  (let ((revision "1")
+        (commit "f9495372801ce4b4dad98ad854203e694c31c1eb"))
+    (package
+      (name "ttyload")
+      (version (git-version "0.5.3" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/lindes/ttyload")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0ldb7a13b9v876c6cbrs78pkizj64drnqx95z5shfbwgpwfhr4im"))))
+      (build-system gnu-build-system)
+      (arguments
+       `(#:tests? #f      ; no tests
+         #:make-flags
+         (list (string-append "CC=" ,(cc-for-target)))
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'configure)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin")))
+                 (install-file "ttyload" bin)))))))
+      (home-page "https://www.daveltd.com/src/util/ttyload/")
+      (synopsis "Console based color-coded graphs of CPU load average")
+      (description
+       "Show graphs for 1 minute, 5 minute, 15 minute load averages on the console.")
+      (license license:expat))))
+
 (define-public htop
   (package
     (name "htop")