diff mbox series

[bug#46484] gnu: postgresql-13: Update to 13.2 [security fixes].

Message ID 20210214210913.18688-1-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#46484] gnu: postgresql-13: Update to 13.2 [security fixes]. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Feb. 14, 2021, 9:09 p.m. UTC
Fixes CVE-2021-3393 and CVE-2021-20229.

* gnu/packages/databases.scm (postgresql-13.2): New variable.
(postgresql-13)[replacement]: New field.

Signed-off-by: Leo Famulari <leo@famulari.name>
---
 gnu/packages/databases.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Leo Famulari Feb. 14, 2021, 9:16 p.m. UTC | #1
On Sun, Feb 14, 2021 at 10:09:13PM +0100, Léo Le Bouter wrote:
> Fixes CVE-2021-3393 and CVE-2021-20229.
> 
> * gnu/packages/databases.scm (postgresql-13.2): New variable.
> (postgresql-13)[replacement]: New field.
> 
> Signed-off-by: Leo Famulari <leo@famulari.name>

Thanks! Pushed as 392e230d5e63fe0f5d7aa9b5085516250630d879
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 9e7e11b380..604b6ad7d6 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1203,6 +1203,7 @@  developed in C/C++ to MariaDB and MySQL databases.")
                (base32
                 "07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))
               (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
+    (replacement postgresql-13.2)
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl"
@@ -1242,6 +1243,20 @@  TIMESTAMP.  It also supports storage of binary large objects, including
 pictures, sounds, or video.")
     (license (license:x11-style "file://COPYRIGHT"))))
 
+(define-public postgresql-13.2
+  (package
+    (inherit postgresql-13)
+    (name "postgresql")
+    (version "13.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://ftp.postgresql.org/pub/source/v"
+                                  version "/postgresql-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1z5d847jnajcfr3wa6jn52a8xjhamvwzmz18xlm5nvxqip8grmsz"))
+              (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
+
 (define-public postgresql-11
   (package
     (inherit postgresql-13)