@@ -1203,6 +1203,7 @@ developed in C/C++ to MariaDB and MySQL databases.")
(base32
"07z6zwr58dckaa97yl9ml240z83d1lhgaxw9aq49i8lsp21mqd0j"))
(patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))
+ (replacement postgresql-13.2)
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-uuid=e2fs" "--with-openssl"
@@ -1242,6 +1243,20 @@ TIMESTAMP. It also supports storage of binary large objects, including
pictures, sounds, or video.")
(license (license:x11-style "file://COPYRIGHT"))))
+(define-public postgresql-13.2
+ (package
+ (inherit postgresql-13)
+ (name "postgresql")
+ (version "13.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://ftp.postgresql.org/pub/source/v"
+ version "/postgresql-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1z5d847jnajcfr3wa6jn52a8xjhamvwzmz18xlm5nvxqip8grmsz"))
+ (patches (search-patches "postgresql-disable-resolve_symlinks.patch"))))))
+
(define-public postgresql-11
(package
(inherit postgresql-13)
Fixes CVE-2021-3393 and CVE-2021-20229. * gnu/packages/databases.scm (postgresql-13.2): New variable. (postgresql-13)[replacement]: New field. Signed-off-by: Leo Famulari <leo@famulari.name> --- gnu/packages/databases.scm | 15 +++++++++++++++ 1 file changed, 15 insertions(+)