diff mbox series

[bug#46471,2/2] gnu: Add run.

Message ID 20210212215154.81746-2-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46470,1/2] gnu: Add go-github-com-tekwizely-go-parsing. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 12, 2021, 9:51 p.m. UTC
* gnu/packages/task-runners.scm (run): New variable.
---
I didn't find a good fit for this package.
I considered build-tools.scm or parallel.scm.
Therefor I created task-runners.scm. I will most likely add some more into this file in the future.
I am not sure, if adding the new file to local.mk is all that is needed for a new packages .scm file.

 gnu/local.mk                  |  1 +
 gnu/packages/task-runners.scm | 48 +++++++++++++++++++++++++++++++++++
 2 files changed, 49 insertions(+)
 create mode 100644 gnu/packages/task-runners.scm

Comments

Ludovic Courtès March 17, 2021, 9:34 p.m. UTC | #1
Stefan Reichör <stefan@xsteve.at> skribis:

> * gnu/packages/task-runners.scm (run): New variable.

It was pushed as adae5d75b6029b5d034030cff24e1ba4d8b3144a so closing.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 0625c6c5eb..2b782e411c 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -533,6 +533,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/synergy.scm			\
   %D%/packages/syndication.scm			\
   %D%/packages/task-management.scm		\
+  %D%/packages/task-runners.scm			\
   %D%/packages/tbb.scm				\
   %D%/packages/tcl.scm				\
   %D%/packages/telegram.scm                 \
diff --git a/gnu/packages/task-runners.scm b/gnu/packages/task-runners.scm
new file mode 100644
index 0000000000..150a377204
--- /dev/null
+++ b/gnu/packages/task-runners.scm
@@ -0,0 +1,48 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages task-runners)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix git-download)
+  #:use-module (gnu packages golang)
+  #:use-module (guix build-system go))
+
+(define-public run
+  (package
+    (name "run")
+    (version "0.7.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/TekWizely/run")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "17n11lqhywq4z62w2rakdq80v7mxf83rgln19vj4v4nxpwd2hjjw"))))
+    (build-system go-build-system)
+    (propagated-inputs
+     `(("go-github-com-tekwizely-go-parsing" ,go-github-com-tekwizely-go-parsing)))
+    (arguments
+     `(#:import-path "github.com/tekwizely/run"))
+    (synopsis "Easily manage and invoke small scripts and wrappers")
+    (description "Easily manage and invoke small scripts and wrappers by using
+a Runfile.")
+    (home-page "https://github.com/TekWizely/run")
+    (license license:expat)))