diff mbox series

[bug#46449] gnu: Add python-mistletoe.

Message ID 20210211213654.117065-1-noisytoot@disroot.org
State Accepted
Headers show
Series [bug#46449] gnu: Add python-mistletoe. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Ron Nazarov Feb. 11, 2021, 9:36 p.m. UTC
* gnu/packages/python-xyz.scm (python-mistletoe): New variable.
---
 gnu/packages/python-xyz.scm | 39 ++++++++++++++++++++++++++++++-------
 1 file changed, 32 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 783812eb03..69a2f29fcb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -96,6 +96,7 @@ 
 ;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -23745,18 +23746,42 @@  Application Programming Interface based on the Open Inventor 2.1 API.")
     (name "python-crayons")
     (version "0.4.0")
     (source
-      (origin
-        (method url-fetch)
-        (uri (pypi-uri "crayons" version))
-        (sha256
-         (base32
-          "0gw106k4b6y8mw7pp52awxyplj2bwvwk315k4sywzwh0g1abfcxx"))))
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "crayons" version))
+       (sha256
+        (base32
+         "0gw106k4b6y8mw7pp52awxyplj2bwvwk315k4sywzwh0g1abfcxx"))))
     (build-system python-build-system)
     (propagated-inputs
-      `(("python-colorama" ,python-colorama)))
+     `(("python-colorama" ,python-colorama)))
     (home-page "https://github.com/MasterOdin/crayons")
     (synopsis "TextUI colors for Python")
     (description "This package gives you colored strings for the terminal.
 Crayons automatically wraps a given string in the foreground color and
 restores the original state after the string is printed.")
     (license license:expat)))
+
+(define-public python-mistletoe
+  (package
+    (name "python-mistletoe")
+    (version "0.7.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "mistletoe" version))
+       (sha256
+        (base32
+         "18z6hqfnfjqnrcgfgl5pkj9ggf9yx0yyy94azcn1qf7hqn6g3l14"))))
+    (build-system python-build-system)
+    (home-page
+     "https://github.com/miyuchina/mistletoe")
+    (synopsis
+     "Fast, extensible Markdown parser in pure Python")
+    (description
+     "A CommonMark-compliant Markdown parser
+that supports easy definitions of custom tokens.
+Parsing Markdown into an abstract syntax tree also allows mistletoe
+to swap out renderers for different output formats,
+without touching any of the core components.")
+    (license license:expat)))