diff mbox series

[bug#46427] gnu: Add tiramisu.

Message ID 20210210180301.32179-1-stefan@xsteve.at
State Accepted
Headers show
Series [bug#46427] gnu: Add tiramisu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Stefan Reichör Feb. 10, 2021, 6:03 p.m. UTC
* gnu/packages/gnome-xyz.scm (tiramisu): New variable.
---
 gnu/packages/gnome-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

宋文武 Feb. 11, 2021, 10:17 a.m. UTC | #1
Stefan Reichör <stefan@xsteve.at> writes:

> * gnu/packages/gnome-xyz.scm (tiramisu): New variable.
> ---
>  gnu/packages/gnome-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
>  1 file changed, 39 insertions(+)
> [...]
> +
> +(define-public tiramisu
> +  (package
> +    (name "tiramisu")
> +    (version "1.0a")

I changed this "1.0a" to 'git-version'.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index eb99fda78e..5743f5999a 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Ellis Kenyo <me@elken.dev>
+;;; Copyright © 2020 Stefan Reichör <stefan@xsteve.at>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -32,6 +33,7 @@ 
   #:use-module (guix build-system meson)
   #:use-module (guix git-download)
   #:use-module (guix packages)
+  #:use-module (guix utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
@@ -888,3 +890,40 @@  feature-set for programming Vala effectively.")
    (description "Nordic is a Gtk3.20+ theme created using the Nord color
 pallete.")
    (license license:gpl3))))
+
+(define-public tiramisu
+  (package
+    (name "tiramisu")
+    (version "1.0a")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Sweets/tiramisu")
+                    (commit "8eb946dae0e2f98d3850d89e1bb535640e8c3266")))
+              (sha256
+               (base32
+                "0wz2r8369d40vnxswknx0zxzbs03gzv0nc8al4g0ffg972p15j25"))
+              (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'check)
+         (replace 'install
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out")))
+               (install-file "tiramisu" (string-append out "/bin"))
+               #t))))
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target)))))
+    (inputs
+     `(("glib" ,glib)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/Sweets/tiramisu")
+    (synopsis "Desktop notifications, the UNIX way")
+    (description "tiramisu is a notification daemon based on dunst that
+outputs notifications to STDOUT in order to allow the user to process
+notifications any way they prefer.")
+    (license license:expat)))