diff mbox series

[bug#46392] gnu: Add nixfmt.

Message ID 20210209011452.6841-1-eu@euandre.org
State Accepted
Headers show
Series [bug#46392] gnu: Add nixfmt. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

EuAndreh Feb. 9, 2021, 1:14 a.m. UTC
* gnu/packages/haskell-xyz.scm (nixfmt): New variable.
---
A quick note: the Hackage importer worked suprisingly well. It was even
able to properly define the synopsis and description fields!

 gnu/packages/haskell-xyz.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Nicolas Goaziou Feb. 21, 2021, 12:50 a.m. UTC | #1
Hello,

EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/haskell-xyz.scm (nixfmt): New variable.

I renamed it ghc-nixfmt and pushed. Thank you.

Regards,
EuAndreh Feb. 21, 2021, 3:33 a.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> I renamed it ghc-nixfmt and pushed. Thank you.

Thanks.

Quick question: why rename it to ghc-nixfmt?

I chose to not add the "ghc-" prefix because this wasn't primarily a
library available for the Haskell ecosystem, but a standalone program
that happens to be written in Haskell.  Could you give me some tip on
the naming covention on this case?

I'm just wondering so that I can pick better names next time.
Nicolas Goaziou Feb. 21, 2021, 9:31 a.m. UTC | #3
Hello,

EuAndreh <eu@euandre.org> writes:

> Quick question: why rename it to ghc-nixfmt?
>
> I chose to not add the "ghc-" prefix because this wasn't primarily a
> library available for the Haskell ecosystem, but a standalone program
> that happens to be written in Haskell.  Could you give me some tip on
> the naming covention on this case?

Good question. I prefixed it with "ghc-" because you put it in
haskell-xyz.scm, where the prefix is usual. If this is a standalone
program, it could go in haskell-apps.scm, with its prefix removed.

I don't think that warrants a deprecation warning since the package is
very young.

WDYT?

Regards,
EuAndreh Feb. 21, 2021, 9:05 p.m. UTC | #4
> WDYT?

Agreed.  Should I send a patch or you'll do the change?
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d6c50ade71..aff3303cb3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -28,6 +28,7 @@ 
 ;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
 ;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
 ;;; Copyright © 2020 Christopher Lemmer Webber <cwebber@dustycloud.org>
+;;; Copyright © 2021 EuAndreh <eu@euandre.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8693,6 +8694,36 @@  making this package a full replacement for the original newtype package,
 and an alternative to newtype-th.")
     (license license:bsd-3)))
 
+(define-public nixfmt
+  (package
+    (name "nixfmt")
+    (version "0.4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/nixfmt/nixfmt-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "1ispgl8rc2scr6v8bb6sks7px856jf61x74zj2iyddrn5qamkb3n"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-megaparsec" ,ghc-megaparsec)
+        ("ghc-parser-combinators" ,ghc-parser-combinators)
+        ("ghc-cmdargs" ,ghc-cmdargs)
+        ("ghc-safe-exceptions" ,ghc-safe-exceptions)))
+    (arguments
+      `(#:cabal-revision
+        ("1" "1hsj0jh6siph3afd9c2wii09sffl48rzqv653n4clpd8qy0rn48d")))
+    (home-page "https://github.com/serokell/nixfmt")
+    (synopsis "An opinionated formatter for Nix")
+    (description
+      "A formatter for Nix that ensures consistent and clear formatting
+by forgetting all existing formatting during parsing.")
+    (license license:mpl2.0)))
+
 (define-public ghc-non-negative
   (package
     (name "ghc-non-negative")