diff mbox series

[bug#46337] A patch to enable building proprietary codecs in qtwebengine

Message ID 20210208234442.00967d36@runbox.com
State Accepted
Headers show
Series [bug#46337] A patch to enable building proprietary codecs in qtwebengine | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

pkill9 Feb. 8, 2021, 11:44 p.m. UTC
I accidentally used two dashes instead of one, here is another patch
that fixes this.

Comments

Leo Famulari Feb. 9, 2021, 9:17 p.m. UTC | #1
On Mon, Feb 08, 2021 at 11:44:42PM +0000, pkill9 wrote:
> I accidentally used two dashes instead of one, here is another patch
> that fixes this.

> From f6dde87ee7749727293ade2ef3f9a2fbaf0f7c1f Mon Sep 17 00:00:00 2001
> From: Pkill -9 <pkill9@runbox.com>
> Date: Mon, 8 Feb 2021 22:24:13 +0000
> Subject: [PATCH] gnu/packages/qt.scm: Enable proprietary codecs support (h264)
>  in qtwebengine

It fails like this:

------
starting phase `configure'
Info: creating stash file /tmp/guix-build-qtwebengine-5.15.2.drv-0/qtwebengine-everywhere-src-5.15.2/.qmake.stash
Info: creating cache file /tmp/guix-build-qtwebengine-5.15.2.drv-0/qtwebengine-everywhere-src-5.15.2/.qmake.cache
ERROR: Unknown command line option '-system-openh264'.
command "qmake" "QT_BUILD_PARTS = libs tools" "--" "--webengine-printing-and-pdf=no" "--webengine-ffmpeg=system" "--webengine-icu=system" "--webengine-pepper-plugins=no" "-webengine-proprietary-codecs" "-system-openh264" failed with status 3
------

I know that I said we could test the patch on the build farm, because
this packages requires a lot of resources to build. However, can you at
least make sure that the configure phase succeeds on your end?
diff mbox series

Patch

From f6dde87ee7749727293ade2ef3f9a2fbaf0f7c1f Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 8 Feb 2021 22:24:13 +0000
Subject: [PATCH] gnu/packages/qt.scm: Enable proprietary codecs support (h264)
 in qtwebengine

---
 gnu/packages/qt.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4fbb157600..431c597b8a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1881,6 +1881,7 @@  using the Enchant spell-checking library.")
        ("mesa" ,mesa)
        ("minizip" ,minizip)
        ("nss" ,nss)
+       ("openh264" ,openh264)
        ("opus" ,opus)
        ("pciutils" ,pciutils)
        ("protobuf" ,protobuf)
@@ -1939,7 +1940,9 @@  using the Enchant spell-checking library.")
                        "--webengine-printing-and-pdf=no"
                        "--webengine-ffmpeg=system"
                        "--webengine-icu=system"
-                       "--webengine-pepper-plugins=no")))))
+                       "--webengine-pepper-plugins=no"
+                       "-webengine-proprietary-codecs"
+                       "-system-openh264")))))
        ;; Tests are disabled due to "Could not find QtWebEngineProcess error"
        ;; It's possible this can be fixed by setting QTWEBENGINEPROCESS_PATH
        ;; before running tests.
-- 
2.30.0