diff mbox series

[bug#46337] A patch to enable building proprietary codecs in qtwebengine

Message ID 20210208225307.456a3fd7@runbox.com
State Accepted
Headers show
Series [bug#46337] A patch to enable building proprietary codecs in qtwebengine | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

pkill9 Feb. 8, 2021, 10:53 p.m. UTC
> Thanks!
> 
> It fails like this:

Thanks for testing, I've attached another patch that adds the configure
flag "--system-openh264" based on the examples given under
"Third Party Libraries" on this page
https://doc.qt.io/qt-5/configure-options.html
diff mbox series

Patch

From 8cc8c39e7d765c6213e3fbbf679f1edda2b2c76d Mon Sep 17 00:00:00 2001
From: Pkill -9 <pkill9@runbox.com>
Date: Mon, 8 Feb 2021 22:24:13 +0000
Subject: [PATCH] gnu/packages/qt.scm: Enable proprietary codecs support (h264)
 in qtwebengine

---
 gnu/packages/qt.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4fbb157600..ceb5842755 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1881,6 +1881,7 @@  using the Enchant spell-checking library.")
        ("mesa" ,mesa)
        ("minizip" ,minizip)
        ("nss" ,nss)
+       ("openh264" ,openh264)
        ("opus" ,opus)
        ("pciutils" ,pciutils)
        ("protobuf" ,protobuf)
@@ -1939,7 +1940,9 @@  using the Enchant spell-checking library.")
                        "--webengine-printing-and-pdf=no"
                        "--webengine-ffmpeg=system"
                        "--webengine-icu=system"
-                       "--webengine-pepper-plugins=no")))))
+                       "--webengine-pepper-plugins=no"
+                       "-webengine-proprietary-codecs"
+		       "--system-openh264")))))
        ;; Tests are disabled due to "Could not find QtWebEngineProcess error"
        ;; It's possible this can be fixed by setting QTWEBENGINEPROCESS_PATH
        ;; before running tests.
-- 
2.30.0