diff mbox series

[bug#46386] gnu: qpdfview: Fix qt-5.15 compatibility.

Message ID 20210208154017.6539-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series [bug#46386] gnu: qpdfview: Fix qt-5.15 compatibility. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Timotej Lazar Feb. 8, 2021, 3:40 p.m. UTC
* gnu/packages/pdf.scm (qpdfview)[source]: Add patch to include a missing
header.
* gnu/packages/patches/qpdfview-qt515-compat.patch: New file, from upstream.
* gnu/local.mk (dist_patch_DATA): Register it.
---
 gnu/local.mk                                     |  1 +
 gnu/packages/patches/qpdfview-qt515-compat.patch | 12 ++++++++++++
 gnu/packages/pdf.scm                             |  3 ++-
 3 files changed, 15 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/qpdfview-qt515-compat.patch

Comments

Leo Famulari Feb. 9, 2021, 7:53 p.m. UTC | #1
On Mon, Feb 08, 2021 at 04:40:17PM +0100, Timotej Lazar wrote:
> * gnu/packages/pdf.scm (qpdfview)[source]: Add patch to include a missing
> header.
> * gnu/packages/patches/qpdfview-qt515-compat.patch: New file, from upstream.
> * gnu/local.mk (dist_patch_DATA): Register it.

Thank you!

I tweaked the patch comments and the commit message and pushed as
1e9f667708ba6fdc4b16fe6851bc0ea0b6306fad
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index ae64a483b5..fe955bb2b7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1562,6 +1562,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/pypy3-7.3.1-fix-tests.patch		\
   %D%/packages/patches/qemu-build-info-manual.patch		\
   %D%/packages/patches/qemu-glibc-2.27.patch 			\
+  %D%/packages/patches/qpdfview-qt515-compat.patch		\
   %D%/packages/patches/qrcodegen-cpp-make-install.patch		\
   %D%/packages/patches/qt4-ldflags.patch			\
   %D%/packages/patches/qtbase-absolute-runpath.patch		\
diff --git a/gnu/packages/patches/qpdfview-qt515-compat.patch b/gnu/packages/patches/qpdfview-qt515-compat.patch
new file mode 100644
index 0000000000..627b8c8907
--- /dev/null
+++ b/gnu/packages/patches/qpdfview-qt515-compat.patch
@@ -0,0 +1,12 @@ 
+From <https://bazaar.launchpad.net/~adamreichold/qpdfview/trunk/revision/2104>.
+--- a/sources/model.h	2017-04-19 21:01:25 +0000
++++ b/sources/model.h	2020-06-09 06:24:11 +0000
+@@ -24,6 +24,7 @@
+ #define DOCUMENTMODEL_H
+ 
+ #include <QList>
++#include <QPainterPath>
+ #include <QtPlugin>
+ #include <QWidget>
+ #include <QVector>
+
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66e920a7bb..3063aa10c0 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -869,7 +869,8 @@  program capable of converting PDF into other formats.")
                            "trunk/" version "/+download/"
                            "qpdfview-" version ".tar.gz"))
        (sha256
-        (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))))
+        (base32 "0v1rl126hvblajnph2hkansgi0s8vjdc5yxrm4y3faa0lxzjwr6c"))
+       (patches (search-patches "qpdfview-qt515-compat.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))