diff mbox series

[bug#46357] gnu: xpdf: Update to 4.03.

Message ID 20210207114033.16634-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#46357] gnu: xpdf: Update to 4.03. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Feb. 7, 2021, 11:40 a.m. UTC
* gnu/packages/pdf.scm (xpdf): Update to 4.03.
(source): Use a "dl.xpdfreader.com" URL.
(build-system): Use cmake-build-system.
(arguments): Remove #:parallel-build?, #:configure-flags and #:phases
(inputs): Add cups, freetype & qtbase, remove gs-fonts, lesstif, libpaper
libx11, libxext, libxp, libxpm & libxt.
---
 gnu/packages/pdf.scm | 42 ++++++++----------------------------------
 1 file changed, 8 insertions(+), 34 deletions(-)

Comments

Leo Famulari Feb. 9, 2021, 8:45 p.m. UTC | #1
On Sun, Feb 07, 2021 at 12:40:33PM +0100, Vincent Legoll wrote:
> * gnu/packages/pdf.scm (xpdf): Update to 4.03.
> (source): Use a "dl.xpdfreader.com" URL.
> (build-system): Use cmake-build-system.
> (arguments): Remove #:parallel-build?, #:configure-flags and #:phases
> (inputs): Add cups, freetype & qtbase, remove gs-fonts, lesstif, libpaper
> libx11, libxext, libxp, libxpm & libxt.

Thank you for taking care of this complicated update!

I tweaked the commit message and pushed as
35089dca4053bf5888441d1648086cdadb6eb1e4

I made the commit message like this:

------
gnu: Xpdf: Update to 4.03.

* gnu/packages/pdf.scm (xpdf): Update to 4.03.
[source]: Update URL.
[build-system]: Use cmake-build-system.
[arguments]: Remove #:parallel-build?, #:configure-flags and #:phases.
[inputs]: Add cups, freetype & qtbase. Remove gs-fonts, lesstif, libpaper
libx11, libxext, libxp, libxpm & libxt.
------

The important difference is the use of () and [].

Basically, when we make changes to variables and functions — things that
are explicitly defined or exported — we put their names (parentheses).

Then, we describe changes to their components or fields in [brackets].

Does that make sense? I would have tweaked the commit message for your
vorbis-tools commit but I didn't notice the "(source)".

The general format, GNU ChangeLog, is described here:

https://www.gnu.org/prep/standards/html_node/Change-Logs.html
Vincent Legoll Feb. 16, 2021, 6:32 p.m. UTC | #2
Hello Leo,

Thanks for taking care of this.

On Tue, Feb 9, 2021 at 9:45 PM Leo Famulari <leo@famulari.name> wrote:
> The important difference is the use of () and [].
>
> Basically, when we make changes to variables and functions — things that
> are explicitly defined or exported — we put their names (parentheses).
>
> Then, we describe changes to their components or fields in [brackets].
>
> Does that make sense?

Yes

> The general format, GNU ChangeLog, is described here:
>
> https://www.gnu.org/prep/standards/html_node/Change-Logs.html

I read it once, but I need to get better at actually doing it.

Cheers
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66e920a7bb..dc7df3fa28 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -396,47 +396,21 @@  reading and editing of existing PDF files.")
 (define-public xpdf
   (package
    (name "xpdf")
-   (version "4.02")
+   (version "4.03")
    (source
     (origin
       (method url-fetch)
-      (uri (string-append "https://xpdfreader-dl.s3.amazonaws.com/xpdf-"
-                          version "4.02.tar.gz"))
+      (uri (string-append "https://dl.xpdfreader.com/xpdf-" version ".tar.gz"))
       (sha256
-       (base32 "1rbp54mr3z2x3a3a1qmz8byzygzi223vckfam9ib5g1sfds0qf8i"))))
-   (build-system gnu-build-system)
-   (inputs `(("freetype" ,freetype)
-             ("gs-fonts" ,gs-fonts)
-             ("lesstif" ,lesstif)
-             ("libpaper" ,libpaper)
-             ("libx11" ,libx11)
-             ("libxext" ,libxext)
-             ("libxp" ,libxp)
-             ("libxpm" ,libxpm)
-             ("libxt" ,libxt)
+       (base32 "0ip81c9vy0igjnasl9iv2lz214fb01vvvdzbvjmgwc63fi1jgr0g"))))
+   (build-system cmake-build-system)
+   (inputs `(("cups" ,cups)
+             ("freetype" ,freetype)
              ("libpng" ,libpng)
+             ("qtbase" ,qtbase)
              ("zlib" ,zlib)))
    (arguments
-    `(#:tests? #f                     ; there is no check target
-      #:parallel-build? #f            ; build fails randomly on 8-way machines
-      #:configure-flags
-        (list (string-append "--with-freetype2-includes="
-                             (assoc-ref %build-inputs "freetype")
-                             "/include/freetype2"))
-      #:phases
-      (modify-phases %standard-phases
-        (replace 'install
-          (lambda* (#:key outputs inputs #:allow-other-keys #:rest args)
-            (let* ((install (assoc-ref %standard-phases 'install))
-                   (out (assoc-ref outputs "out"))
-                   (xpdfrc (string-append out "/etc/xpdfrc"))
-                   (gs-fonts (assoc-ref inputs "gs-fonts")))
-              (apply install args)
-              (substitute* xpdfrc
-                (("/usr/local/share/ghostscript/fonts")
-                 (string-append gs-fonts "/share/fonts/type1/ghostscript"))
-                (("#fontFile") "fontFile")))
-            #t)))))
+    `(#:tests? #f))                   ; there is no check target
    (synopsis "Viewer for PDF files based on the Motif toolkit")
    (description
     "Xpdf is a viewer for Portable Document Format (PDF) files.")