diff mbox series

[bug#46352,3/4] gnu: nqp: Update to 2020.12.

Message ID 20210206213511.11551-3-brown121407@posteo.ro
State New
Headers show
Series Update Raku (Perl 6) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Alexandru-Sergiu Marton Feb. 6, 2021, 9:35 p.m. UTC
* gnu/packages/perl6.scm (nqp): Update to 2020.12.
---
 gnu/packages/perl6.scm | 45 +++++++++++++++++-------------------------
 1 file changed, 18 insertions(+), 27 deletions(-)

Comments

Ludovic Courtès March 20, 2021, 9:10 p.m. UTC | #1
Alexandru-Sergiu Marton <brown121407@posteo.ro> skribis:

> * gnu/packages/perl6.scm (nqp): Update to 2020.12.

[...]

> -         '(begin
> -            (delete-file-recursively "3rdparty") #t))))

[...]

> +        '(begin
> +           (delete-file-recursively "3rdparty/asm")
> +           (delete-file-recursively "3rdparty/jline")
> +           (delete-file-recursively "3rdparty/jna")

This suggests we’re now using some of the bundled libraries.  Could you
explain and at least add a comment mentioning what’s still bundled?

Please also mention the phase changes in the commit log.

Thanks in advance!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 96d76dd417..3395d3a2ec 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -108,19 +108,22 @@  with native libraries.
 (define-public nqp
   (package
     (name "nqp")
-    (version "2019.03")
+    (version "2020.12")
     (source
-      (origin
-        (method url-fetch)
-        (uri (string-append "https://rakudo.perl6.org/downloads/nqp/nqp-"
-                            version ".tar.gz"))
-        (sha256
-         (base32
-          "183zhll13fx416s3hkg4bkvib77kyr857h0nydgrl643fpacxp83"))
-        (modules '((guix build utils)))
-        (snippet
-         '(begin
-            (delete-file-recursively "3rdparty") #t))))
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/Raku/nqp/releases/download/" version
+                           "/nqp-" version ".tar.gz"))
+       (sha256
+        (base32
+         "13h64d41fwggc3lg4bpllg4jrp64clm7nmnw4g2jyjl47cy5ni7x"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (delete-file-recursively "3rdparty/asm")
+           (delete-file-recursively "3rdparty/jline")
+           (delete-file-recursively "3rdparty/jna")
+           #t))))
     (build-system perl-build-system)
     (arguments
      '(#:phases
@@ -131,33 +134,21 @@  with native libraries.
                             "tools/build/gen-js-cross-runner.pl"
                             "tools/build/gen-js-runner.pl"
                             "tools/build/install-js-runner.pl"
-                            "tools/build/install-moar-runner.pl"
-                            "tools/build/gen-moar-runner.pl"
                             "t/nqp/111-spawnprocasync.t"
                             "t/nqp/113-run-command.t")
                (("/bin/sh") (which "sh")))
              #t))
-         (add-after 'unpack 'patch-source-date
-           (lambda _
-             (substitute* "tools/build/gen-version.pl"
-               (("gmtime") "gmtime(0)"))
-             #t))
-         (add-after 'unpack 'remove-failing-test
-           ;; One subtest fails for unknown reasons
-           (lambda _
-             (delete-file "t/nqp/019-file-ops.t")
-             #t))
          (replace 'configure
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out  (assoc-ref outputs "out"))
                    (moar (assoc-ref inputs "moarvm")))
                (invoke "perl" "Configure.pl"
                        "--backends=moar"
-                       "--with-moar" (string-append moar "/bin/moar")
-                       "--prefix" out)))))))
+                       (string-append "--with-moar=" moar "/bin/moar")
+                       (string-append "--prefix=" out))))))))
     (inputs
      `(("moarvm" ,moarvm)))
-    (home-page "https://github.com/perl6/nqp")
+    (home-page "https://github.com/Raku/nqp")
     (synopsis "Not Quite Perl")
     (description "This is \"Not Quite Perl\" -- a lightweight Perl 6-like
 environment for virtual machines.  The key feature of NQP is that it's designed