diff mbox series

[bug#46311] gnu: Add cockatrice.

Message ID 20210204233352.24166-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#46311] gnu: Add cockatrice. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Feb. 4, 2021, 11:33 p.m. UTC
* gnu/packages/games.scm (cockatrice): New variable.
---
 gnu/packages/games.scm | 46 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

Nicolas Goaziou Feb. 5, 2021, 3:31 p.m. UTC | #1
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> +      (description "Cockatrice is an open-source, multiplatform program for
> +playing tabletop card games over a network.  

I suggest to remove "open-source" and "multiplatform" from the
description.

Otherwise, LGTM!

Regards,
Leo Prikler Feb. 5, 2021, 4:39 p.m. UTC | #2
Hello,

Am Freitag, den 05.02.2021, 16:31 +0100 schrieb Nicolas Goaziou:
> I suggest to remove "open-source" and "multiplatform" from the
> description.
> 
> Otherwise, LGTM!
Changed and pushed.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index e3e18bf09e..953fd317ed 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -857,6 +857,52 @@  things far stranger and deadlier, and against the others like yourself, that
 want what you have.")
     (license license:cc-by-sa3.0)))
 
+(define-public cockatrice
+  (let ((release-date "2021-01-26"))
+    (package
+      (name "cockatrice")
+      (version "2.8.0")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Cockatrice/Cockatrice")
+               (commit (string-append release-date "-Release-" version))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0q8ffcklb2b7hcqhy3d2f9kz9aw22pp04pc9y4sslyqmf17pwnz9"))
+         (modules '((guix build utils)))
+         (snippet
+          ;; Strip image URLs as they point towards non-free web services
+          '(substitute* "cockatrice/src/settings/downloadsettings.cpp"
+             (("downloadURLs.append\\(\".*\"\\);") "")))))
+      (build-system cmake-build-system)
+      (arguments
+       `(#:configure-flags '("-DWITH_SERVER=1"
+                             "-DWITH_CLIENT=1"
+                             "-DWITH_ORACLE=1"
+                             "-DTEST=1")))
+      (native-inputs
+       `(("googletest" ,googletest)
+         ("pkg-config" ,pkg-config)))
+      (inputs
+       `(("protobuf" ,protobuf)
+         ("qtbase" ,qtbase)
+         ("qtmultimedia" ,qtmultimedia)
+         ("qtsvg" ,qtsvg)
+         ("qttools" ,qttools)
+         ("qtwebsockets" ,qtwebsockets)
+         ("xz" ,xz)
+         ("zlib" ,zlib)))
+      (home-page "https://cockatrice.github.io")
+      (synopsis "Tabletop card game simulator")
+      (description "Cockatrice is an open-source, multiplatform program for
+playing tabletop card games over a network.  The program's server design
+prevents users from manipulating the game for unfair advantage.  The client
+also provides a single-player mode, which allows users to brew while offline.")
+      (license license:gpl2))))
+
 (define-public corsix-th
   (package
     (name "corsix-th")