diff mbox series

[bug#46305] gnu: miredo: Fix creation of .pid file.

Message ID 20210204223353.2730-1-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#46305] gnu: miredo: Fix creation of .pid file. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Léo Le Bouter Feb. 4, 2021, 10:33 p.m. UTC
* gnu/packages/networking.scm (miredo)[arguments]: Add "--localstatedir=/var"
to #:configure-flags and add 'do-not-create-/run phase to #:phases to remove
code that tries to create a directory inside "@localstatedir@" during install.
---
 gnu/packages/networking.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

宋文武 Feb. 11, 2021, 9:20 a.m. UTC | #1
Léo Le Bouter <lle-bout@zaclys.net> writes:

> * gnu/packages/networking.scm (miredo)[arguments]: Add "--localstatedir=/var"
> to #:configure-flags and add 'do-not-create-/run phase to #:phases to remove
> code that tries to create a directory inside "@localstatedir@" during install.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index abaab60f31..5e0022ac76 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -700,8 +700,16 @@  or, more generally, MAC addresses of the same category of hardware.")
                 "0j9ilig570snbmj48230hf7ms8kvcwi2wblycqrmhh85lksd49ps"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     '(#:configure-flags
+       (list "--localstatedir=/var")
+       #:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'do-not-create-/run
+           (lambda _
+             (substitute* (find-files "src" "Makefile.*")
+               (("^.+install_sh.+/run.+$")
+                "\ttrue"))
+             #t))
          (add-after 'unpack 'patch-iproute2
            (lambda* (#:key inputs #:allow-other-keys)
              (let* ((iproute (assoc-ref inputs "iproute"))