diff mbox series

[bug#46192,04/21] gnu: Add rust-jsonrpc-core-14.

Message ID 20210204113743.cbwogsiennu46lfw@minitower
State Accepted
Headers show
Series None | expand

Commit Message

aecepoglu Feb. 4, 2021, 11:37 a.m. UTC
* gnu/packages/crates-io.scm (rust-jsonrpc-core-14): New variable.
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index eb550ce9f0..312f39fda6 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -17419,6 +17419,35 @@  the jni-bindgen code generator for binding to JVM APIs from Rust.")
      "An implementation of the GNU make jobserver for Rust.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-jsonrpc-core-14
+  (package
+    (name "rust-jsonrpc-core")
+    (version "14.2.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "jsonrpc-core" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0qkvgkr05sg0j25jqgw7zcw4r1agzg8gnfnrmw1rgyqz283p6x50"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:cargo-inputs
+        (("rust-futures" ,rust-futures-0.1)
+         ("rust-log" ,rust-log-0.4)
+         ("rust-serde" ,rust-serde-1)
+         ("rust-serde-derive" ,rust-serde-derive-1)
+         ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page
+      "https://github.com/paritytech/jsonrpc")
+    (synopsis
+      "Transport agnostic rust implementation of JSON-RPC 2.0 Specification.")
+    (description
+      "Transport agnostic rust implementation of JSON-RPC 2.0 Specification.")
+    (license license:expat)))
+
 (define-public rust-js-sys-0.3
   (package
     (name "rust-js-sys")