diff mbox series

[bug#46262] gnu: Add font-canada1500.

Message ID 20210203005918.42643-1-antoine.cote@posteo.net
State Accepted
Headers show
Series [bug#46262] gnu: Add font-canada1500. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antoine Côté Feb. 3, 2021, 12:59 a.m. UTC
* gnu/packages/fonts.scm (font-canada1500): New variable.
---
 gnu/packages/fonts.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

宋文武 Feb. 13, 2021, 3:06 a.m. UTC | #1
Antoine Côté <antoine.cote@posteo.net> writes:

> * gnu/packages/fonts.scm (font-canada1500): New variable.
> ---
>  gnu/packages/fonts.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> [...]
> +    (description "A free display typeface originally created for the Canadian

Hello, I changed this to "Canada1500 is a display typeface ...", as we
need full sentence with subject in description.

Pushed, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6011a24c5e..2e18d55115 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -199,6 +199,25 @@  package provides the TrueType (TTF) files.")
 no copy of one or more of the Font Software typefaces may be sold by
 itself."))))
 
+(define-public font-canada1500
+  (package
+    (name "font-canada1500")
+    (version "1.101")
+    (source (origin
+              (method url-fetch)
+              (uri "https://typodermicfonts.com/wp-content/uploads/2017/06/canada1500.zip")
+              (sha256
+               (base32
+                "052rwhyfcz6q0g0nsr21bkbg2qb6sw7wzins5hv80qhdhi77sdaj"))))
+    (build-system font-build-system)
+    (home-page "https://typodermicfonts.com/canada1500/")
+    (synopsis "Canadian typeface that supports English, French and Aboriginal languages")
+    (description "A free display typeface originally created for the Canadian
+sesquicentennial with four weights, italics and space symbols which includes
+lining and old-style numerals, tabular and proportional.  Greek, Cyrillic,
+Canadian Syllabics and most Latin based languages are supported.")
+    (license license:cc0)))
+
 (define-public font-cantarell
   (package
     (name "font-abattis-cantarell")