diff mbox series

[bug#46260] gnu: Add font-space-grotesk.

Message ID 20210202203802.37583-1-antoine.cote@posteo.net
State Accepted
Headers show
Series [bug#46260] gnu: Add font-space-grotesk. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antoine Côté Feb. 2, 2021, 8:38 p.m. UTC
* gnu/packages/fonts.scm (font-space-grotesk): New variable.
---
 gnu/packages/fonts.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

vasilii.smirnov--- via Guix-patches" via Feb. 2, 2021, 10:04 p.m. UTC | #1
Antoine,

Antoine Côté 写道:
> * gnu/packages/fonts.scm (font-space-grotesk): New variable.

Thanks!

> +(define-public font-space-grotesk

Aim to add packages in alphabetical order, to minimise merge 
conflicts (unlikely but they happen).  Some modules, like this 
one, are such a mess that your only option is 
alphabetical-compared-to-the-previous-variable.  Oh well.  I moved 
it under font-sarasa-gothic.

> +    (build-system font-build-system)

And added a phase to install OFL.txt as well.

> +    (synopsis "Proportional variant of the original fixed-width 
> Space Mono family")
> +    (description "Space Grotesk is a proportional sans-serif 
> typeface variant based on Colophon Foundry's
> +fixed-width Space Mono family (2016).  Originally designed by 
> Florian Karsten in 2018,
> +Space Grotesk retains the monospace's idiosyncratic details 
> while optimizing for
> +improved readability at non-display sizes.  Space Grotesk 
> includes Latin Vietnamese,
> +Pinyin, and all Western, Central, and South-Eastern European 
> language support,
> +as well as several OpenType features (old-style and tabular 
> figures,
> +superscript and subscript numerals, fractions, stylistic 
> alternates).")

These lines are a bit too long.  You should configure your editor 
to wrap at 78 characters or at least not exceed 80.

I shortened the synopsis + description just a tiny bit and pushed 
this package as d65a25c9a2fdc9940c691afd8a10c7d489052cdf.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index c2c0db43c0..6011a24c5e 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2061,3 +2061,28 @@  operators and special symbols.")
 is a stylish type with a polished yet relaxed feel.  Its versatility makes it
 suitable for a wide range of uses.")
       (license license:silofl1.1))))
+
+(define-public font-space-grotesk
+  (package
+    (name "font-space-grotesk")
+    (version "2.0.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/floriankarsten/space-grotesk")
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1aiivn0rl7ydiyqvsr0fa2hx82h3br3x48w3100fcly23n0fdcby"))))
+    (build-system font-build-system)
+    (home-page "https://floriankarsten.github.io/space-grotesk/")
+    (synopsis "Proportional variant of the original fixed-width Space Mono family")
+    (description "Space Grotesk is a proportional sans-serif typeface variant based on Colophon Foundry's
+fixed-width Space Mono family (2016).  Originally designed by Florian Karsten in 2018,
+Space Grotesk retains the monospace's idiosyncratic details while optimizing for
+improved readability at non-display sizes.  Space Grotesk includes Latin Vietnamese,
+Pinyin, and all Western, Central, and South-Eastern European language support,
+as well as several OpenType features (old-style and tabular figures,
+superscript and subscript numerals, fractions, stylistic alternates).")
+    (license license:silofl1.1)))