diff mbox series

[bug#46235] gnu: emacs-rg: Fix use on remote systems.

Message ID 20210201124721.3767-1-clement@lassieur.org
State Accepted
Headers show
Series [bug#46235] gnu: emacs-rg: Fix use on remote systems. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Clément Lassieur Feb. 1, 2021, 12:47 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-rg)[inputs]: Remove.  Move ripgrep to...
[propagated-inputs]: ... here.  This also gives access to ripgrep's manual.
[arguments]: Replace the full path with the executable name.
---
 gnu/packages/emacs-xyz.scm | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

Comments

Nicolas Goaziou Feb. 2, 2021, 8:27 a.m. UTC | #1
Hello,

Clément Lassieur <clement@lassieur.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-rg)[inputs]: Remove.  Move ripgrep to...
> [propagated-inputs]: ... here.  This also gives access to ripgrep's manual.
> [arguments]: Replace the full path with the executable name.

LGTM!

Regards,
Clément Lassieur Feb. 2, 2021, 8:56 a.m. UTC | #2
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> Hello,
>
> Clément Lassieur <clement@lassieur.org> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-rg)[inputs]: Remove.  Move ripgrep to...
>> [propagated-inputs]: ... here.  This also gives access to ripgrep's manual.
>> [arguments]: Replace the full path with the executable name.
>
> LGTM!
>
> Regards,

Thanks!  Pushed
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 28c7b41d79..ba1865d05f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2017, 2018, 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
-;;; Copyright © 2017, 2018, 2019, 2020 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017, 2018, 2019, 2020, 2021 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2017 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2017, 2018 Kyle Meyer <kyle@kyleam.com>
 ;;; Copyright © 2017 Kei Kebreau <kkebreau@posteo.net>
@@ -3848,19 +3848,18 @@  result.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'hardcode-rg-path
-           ;; Hardcode the path to ripgrep.
+         (add-after 'unpack 'remove-rg-path
+           ;; Remove the path to ripgrep so that it works on remote systems.
            (lambda _
              (let ((file "rg.el"))
                (chmod file #o644)
                (emacs-substitute-sexps file
-                 ("(defcustom rg-executable" (which "rg")))))))))
+                 ("(defcustom rg-executable" "rg"))))))))
     (propagated-inputs
      `(("emacs-s" ,emacs-s)
        ("emacs-transient" ,emacs-transient)
-       ("emacs-wgrep" ,emacs-wgrep)))
-    (inputs
-     `(("ripgrep" ,ripgrep)))
+       ("emacs-wgrep" ,emacs-wgrep)
+       ("ripgrep" ,ripgrep)))
     (home-page "https://rgel.readthedocs.io/en/latest/")
     (synopsis "Search tool based on @code{ripgrep}")
     (description