diff mbox series

[bug#46222,1/1] gnu: pinentry-rofi: Update to 2.0.3.

Message ID 20210201014040.119125-1-plattfot@posteo.net
State Accepted
Headers show
Series gnu: pinentry-rofi: Update to 2.0.3. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson Feb. 1, 2021, 1:40 a.m. UTC
* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.3.
[arguments]: Add make installcheck phase to verify the installed artifact.
---
 gnu/packages/gnupg.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)

Comments

Efraim Flashner Feb. 1, 2021, 10:50 a.m. UTC | #1
Thanks. I also added a line in the commit message about adding
autoconf-archive to native-inputs.
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 9be8a32540..b7f4acc78b 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -894,7 +894,7 @@  passphrase when @code{gpg} is run and needs it.")))
 (define-public pinentry-rofi
   (package
     (name "pinentry-rofi")
-    (version "2.0.2")
+    (version "2.0.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -902,7 +902,7 @@  passphrase when @code{gpg} is run and needs it.")))
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "14rbz32ykc8pz7gglbvxm3pcgabr7xdnddar6k24icd5xk9mr4rp"))))
+               (base32 "0kjzvgni9srl8h5c52pqrvgdxs6avv0nhgk19apd97sx10qdwdhk"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules
@@ -923,10 +923,14 @@  passphrase when @code{gpg} is run and needs it.")))
                   (wrap-program
                       (string-append bin "pinentry-rofi")
                     (list "PATH" ":" 'prefix `(,rofi-bin)))
-                  #t))))))))
+                  #t)))))
+         (add-after 'compress-documentation 'installcheck
+           (lambda* rest
+             (invoke "make" "installcheck"))))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
+       ("autoconf-archive" ,autoconf-archive)
        ("pkg-config" ,pkg-config)
        ("texinfo" ,texinfo)))
     (inputs `(("guile" ,guile-3.0)