diff mbox series

[bug#46213] Updated openimageio (fixes Blender build)

Message ID 20210131012720.1355237a@riseup.net
State Accepted
Headers show
Series [bug#46213] Updated openimageio (fixes Blender build) | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Csepp Jan. 31, 2021, 12:27 a.m. UTC
Blender was failing to build (but ./configure worked), so I updated
openimageio. That fixed it. I'm testing Blender right now and it seems
to be working fine.

Comments

Nicolas Goaziou Jan. 31, 2021, 5:56 p.m. UTC | #1
Hello,

raingloom <raingloom@riseup.net> writes:

> Blender was failing to build (but ./configure worked), so I updated
> openimageio. That fixed it. I'm testing Blender right now and it seems
> to be working fine.

This update is already in master
(e629d7221604726d404b4d280a38d9a698d32a30). Sorry for the duplicate
work!

Closing.

Regards,
diff mbox series

Patch

From f58cb00510864d1732a2ebe79ae37c5ea893439c Mon Sep 17 00:00:00 2001
From: raingloom <raingloom@riseup.net>
Date: Sun, 31 Jan 2021 01:21:53 +0100
Subject: [PATCH] gnu: openimageio: Updated to 2.2.10.1.

* gnu/packages/graphics.scm (openimageio): Update to 2.2.10.1.
  [inputs]: Add fmt.
---
 gnu/packages/graphics.scm | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 411d89fcc2..3b0320101f 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -84,6 +84,7 @@ 
   #:use-module (gnu packages photo)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages plotutils)
+  #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages pth)
   #:use-module (gnu packages pulseaudio)  ; libsndfile, libsamplerate
   #:use-module (gnu packages python)
@@ -538,6 +539,7 @@  applications.")
        ("freetype" ,freetype)
        ("glew" ,glew)
        ("openal" ,openal)
+       ("pugixml" ,pugixml)
        ("python" ,python)
        ("python-numpy" ,python-numpy)
        ("tbb" ,tbb)
@@ -1088,7 +1090,7 @@  storage of the \"EXR\" file format for storing 16-bit floating-point images.")
 (define-public openimageio
   (package
     (name "openimageio")
-    (version "2.0.13")
+    (version "2.2.10.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1097,7 +1099,7 @@  storage of the \"EXR\" file format for storing 16-bit floating-point images.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0czcls82v71wkw1syib16ncg7463hx0py0xclycsiv4w6i3wlkzz"))))
+                "0wzh5n527l7ia1754cf9xmbvv4ya6hj34dy6cbq9xk9372h8gd9q"))))
     (build-system cmake-build-system)
     ;; FIXME: To run all tests successfully, test image sets from multiple
     ;; third party sources have to be present.  For details see
@@ -1111,6 +1113,7 @@  storage of the \"EXR\" file format for storing 16-bit floating-point images.")
        ("libpng" ,libpng)
        ("libjpeg" ,libjpeg-turbo)
        ("libtiff" ,libtiff)
+       ("fmt" ,fmt)
        ("giflib" ,giflib)
        ("openexr" ,openexr)
        ("ilmbase" ,ilmbase)
-- 
2.30.0