diff mbox series

[bug#46192,17/22] gnu: Add rust-slog-scope-4.

Message ID 20210130224448.oqphazzlhrhfzkd5@minitower
State Accepted
Headers show
Series None | expand

Commit Message

aecepoglu Jan. 30, 2021, 10:44 p.m. UTC
* gnu/packages/crates-io.scm (rust-slog-scope-4): New variable.
---
 gnu/packages/crates-io.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 886739a1cf..8e2975e308 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -33101,6 +33101,35 @@  data type.")
             license:expat
             license:asl2.0))))
 
+(define-public rust-slog-scope-4
+  (package
+    (name "rust-slog-scope")
+    (version "4.3.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "slog-scope" version))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1riyabmd2qz984ff6dn5d540p17px99q6cdfs4vlbbmhv2fwhi3w"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build?
+        #t
+        #:cargo-inputs
+        (("rust-arc-swap" ,rust-arc-swap-0.4)
+         ("rust-lazy-static" ,rust-lazy-static-1)
+         ("rust-slog" ,rust-slog-2))))
+    (home-page "https://github.com/slog-rs/slog")
+    (synopsis "Logging scopes for slog-rs")
+    (description "This package provides logging scopes for slog-rs")
+    (license
+      (list license:mpl2.0
+            license:expat
+            license:asl2.0))))
+
 (define-public rust-slog-stdlog-3
   (package
     (name "rust-slog-stdlog")