diff mbox series

[bug#46170] gnu: Add licenseheaders.

Message ID 20210129100948.26041-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#46170] gnu: Add licenseheaders. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Jan. 29, 2021, 10:09 a.m. UTC
* gnu/packages/license.scm (licenseheaders): New variable.
---
 gnu/packages/license.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Nicolas Goaziou Jan. 31, 2021, 4:01 p.m. UTC | #1
Hello,

Tanguy Le Carrour <tanguy@bioneland.org> writes:

> * gnu/packages/license.scm (licenseheaders): New variable.

Applied. Thank you.

> +     "A Python 3 tool to update, change or add license headers to all files
> + of any of the supported types (see below) in or below some
> directory.")

I turned the description into a complete sentence.

Regards,
Tanguy LE CARROUR Jan. 31, 2021, 4:25 p.m. UTC | #2
Hi Nicolas,

Excerpts from Nicolas Goaziou's message of January 31, 2021 5:01 pm:
> Tanguy Le Carrour <tanguy@bioneland.org> writes:
> 
>> * gnu/packages/license.scm (licenseheaders): New variable.
> 
> Applied. Thank you.

Thanks.


>> +     "A Python 3 tool to update, change or add license headers to all files
>> + of any of the supported types (see below) in or below some
>> directory.")
> 
> I turned the description into a complete sentence.

Sorry! Thanks for noticing!
diff mbox series

Patch

diff --git a/gnu/packages/license.scm b/gnu/packages/license.scm
index 369426768b..568275e510 100644
--- a/gnu/packages/license.scm
+++ b/gnu/packages/license.scm
@@ -2,6 +2,7 @@ 
 ;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -205,3 +206,37 @@  tools that have a lot more features and functionality surrounding the analysis
 and inspection of copyright and licenses in software projects.  This one is
 designed to be simple.")
     (license (list asl2.0 gpl3+))))
+
+(define-public licenseheaders
+  (package
+    (name "licenseheaders")
+    (version "0.8.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "licenseheaders" version))
+       (sha256
+        (base32
+         "073xcm10gyg5kcxqmbsyaz9sr0slbdwgr0r9qanch0zl8i0z9259"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         ;; Reported upstream:
+         ;; <https://github.com/johann-petrak/licenseheaders/issues/47>.
+         (add-after 'unpack 'patch-code
+           (lambda _
+             (substitute* "licenseheaders.py"
+               (("\\\"filenames\\\": \\[\\\"CMakeLists.txt\\\"\\],")
+                "\"filenames\": [\"CMakeLists.txt\"], \n        \"extensions\": [],"))
+             #t)))))
+    (propagated-inputs
+     `(("python-regex" ,python-regex)))
+    (home-page
+     "http://github.com/johann-petrak/licenseheaders")
+    (synopsis
+     "Add or change license headers for all files in a directory")
+    (description
+     "A Python 3 tool to update, change or add license headers to all files
+ of any of the supported types (see below) in or below some directory.")
+    (license expat)))