diff mbox series

[bug#46148,1/1] gnu: pinentry-rofi: Update to 2.0.2.

Message ID 20210128020207.149383-1-plattfot@posteo.net
State Accepted
Headers show
Series gnu: pinentry-rofi: Update to 2.0.2. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson Jan. 28, 2021, 2:02 a.m. UTC
* gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2.
* gnu/packages/gnupg.scm (pinentry-rofi): Simplify the package definition.
---
 gnu/packages/gnupg.scm | 39 ++++++++-------------------------------
 1 file changed, 8 insertions(+), 31 deletions(-)

Comments

Nicolas Goaziou Jan. 28, 2021, 1:22 p.m. UTC | #1
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

> * gnu/packages/gnupg.scm (pinentry-rofi): Update to 2.0.2.
> * gnu/packages/gnupg.scm (pinentry-rofi): Simplify the package
> definition.

Applied, with a slight change to commit message.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index 6e80ca339f..9be8a32540 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -894,7 +894,7 @@  passphrase when @code{gpg} is run and needs it.")))
 (define-public pinentry-rofi
   (package
     (name "pinentry-rofi")
-    (version "2.0.1")
+    (version "2.0.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -902,7 +902,7 @@  passphrase when @code{gpg} is run and needs it.")))
                     (commit version)))
               (file-name (git-file-name name version))
               (sha256
-               (base32 "044bnldz7k74s873jwsjgff176l1jsvpbaka7d1wcj8b5pwqv2av"))))
+               (base32 "14rbz32ykc8pz7gglbvxm3pcgabr7xdnddar6k24icd5xk9mr4rp"))))
     (build-system gnu-build-system)
     (arguments
      `(#:modules
@@ -914,38 +914,15 @@  passphrase when @code{gpg} is run and needs it.")))
            %standard-phases
          (add-after 'install 'hall-wrap-binaries
            (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((compiled-dir
-                     (lambda (out version)
-                       (string-append out "/lib/guile/" version "/site-ccache")))
-                    (uncompiled-dir
-                     (lambda (out version)
-                       (string-append
-                        out
-                        "/share/guile/site"
-                        (if (string-null? version) "" "/")
-                        version)))
-                    (dep-path
-                     (lambda (env path)
-                       (list env ":" 'prefix (list path))))
-                    (out (assoc-ref outputs "out"))
+             (let* ((out (assoc-ref outputs "out"))
                     (bin (string-append out "/bin/"))
-                    (site (uncompiled-dir out "")))
+                    (site (string-append out "/share/guile/site"))
+                    (rofi-bin (string-append (assoc-ref inputs "rofi") "/bin")))
                (match (scandir site)
                  (("." ".." version)
-                  (for-each
-                   (lambda (file)
-                     (wrap-program
-                         (string-append bin file)
-                       (dep-path
-                        "PATH"
-                        (string-append (assoc-ref inputs "rofi") "/bin"))
-                       (dep-path
-                        "GUILE_LOAD_PATH"
-                        (uncompiled-dir out version))
-                       (dep-path
-                        "GUILE_LOAD_COMPILED_PATH"
-                        (compiled-dir out version))))
-                   ,''("pinentry-rofi"))
+                  (wrap-program
+                      (string-append bin "pinentry-rofi")
+                    (list "PATH" ":" 'prefix `(,rofi-bin)))
                   #t))))))))
     (native-inputs
      `(("autoconf" ,autoconf)