diff mbox series

[bug#46107,6/6] gnu: Add avogadro2.

Message ID 20210125212248.4749-5-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#46107,1/6] gnu: Add spglib. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kei Kebreau Jan. 25, 2021, 9:22 p.m. UTC
* gnu/packages/chemistry.scm (avogadro2): New variable.
---
 gnu/packages/chemistry.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Leo Famulari Jan. 25, 2021, 10:19 p.m. UTC | #1
On Mon, Jan 25, 2021 at 04:22:48PM -0500, Kei Kebreau wrote:
> * gnu/packages/chemistry.scm (avogadro2): New variable.

Thanks a lot for taking care of this! I sent some other comments, but
they shouldn't block these patches.

LGTM
Kei Kebreau Jan. 26, 2021, 3:24 a.m. UTC | #2
On Mon, 2021-01-25 at 17:19 -0500, Leo Famulari wrote:
> On Mon, Jan 25, 2021 at 04:22:48PM -0500, Kei Kebreau wrote:
> > * gnu/packages/chemistry.scm (avogadro2): New variable.
> 
> Thanks a lot for taking care of this! I sent some other comments, but
> they shouldn't block these patches.
> 
> LGTM

Done and done!  Thanks for reviewing and commenting.  Avogadro is clear for
removal, especially since it doesn't seem to build anymore.
Leo Famulari Jan. 29, 2021, 1:05 a.m. UTC | #3
On Mon, Jan 25, 2021 at 10:24:28PM -0500, Kei wrote:
> Done and done!  Thanks for reviewing and commenting.  Avogadro is clear for
> removal, especially since it doesn't seem to build anymore.

Do you know if avogradro2 is suitable as a "drop-in" replacement for
avogadro? If so, we could mark it as superseded by avogadro2, and then
it would be automatically updated in users' profiles when they do `guix
pull && guix upgrade`.
Kei Kebreau Jan. 29, 2021, 4:28 p.m. UTC | #4
On 2021-01-28 20:05, Leo Famulari wrote:
> On Mon, Jan 25, 2021 at 10:24:28PM -0500, Kei wrote:
>> Done and done!  Thanks for reviewing and commenting.  Avogadro is 
>> clear for
>> removal, especially since it doesn't seem to build anymore.
> 
> Do you know if avogradro2 is suitable as a "drop-in" replacement for
> avogadro? If so, we could mark it as superseded by avogadro2, and then
> it would be automatically updated in users' profiles when they do `guix
> pull && guix upgrade`.

I think so. Development efforts seem to have been focused on Avogadro 2 
for
several years now, with little or no maintenance of the original 
Avogadro. This
2018 community survey [0] indicates the developers' full commitment to
Avogadro 2, so marking it as superseding avogadro is recommended.

[0]: https://avogadro.cc/news/community-survey-results/
Leo Famulari Jan. 29, 2021, 8:20 p.m. UTC | #5
On Fri, Jan 29, 2021 at 11:28:08AM -0500, kkebreau@posteo.net wrote:
> I think so. Development efforts seem to have been focused on Avogadro 2 for
> several years now, with little or no maintenance of the original Avogadro.
> This
> 2018 community survey [0] indicates the developers' full commitment to
> Avogadro 2, so marking it as superseding avogadro is recommended.

Since avogadro doesn't build, I decided to remove it rather than mark it
as superseded.

Removed with commit 42008264d9fff544ee00c3c109093472b8a92bd2
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 9d4c6f07fa..8fe51d79ee 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -179,6 +179,41 @@  processing useful in computational chemistry, molecular modeling,
 bioinformatics, materials science, and related areas.")
     (license license:bsd-3)))
 
+(define-public avogadro2
+  (package
+    (name "avogadro2")
+    (version "1.93.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/OpenChemistry/avogadroapp")
+             (commit version)))
+       (sha256
+        (base32
+         "1z3pjlwja778a1dmvx9aqz2hlw5q9g3kqxhm9slz08452600jsv7"))
+       (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("eigen" ,eigen)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("avogadrolibs" ,avogadrolibs)
+       ("hdf5" ,hdf5)
+       ("molequeue" ,molequeue)
+       ("qtbase" ,qtbase)))
+    ;; TODO: Enable tests with "-DENABLE_TESTING" configure flag.
+    (arguments
+     '(#:tests? #f))
+    (home-page "https://www.openchemistry.org/projects/avogadro2/")
+    (synopsis "Advanced molecule editor")
+    (description
+     "Avogadro 2 is an advanced molecule editor and visualizer designed for use
+in computational chemistry, molecular modeling, bioinformatics, materials
+science, and related areas.  It offers flexible high quality rendering and a
+powerful plugin architecture.")
+    (license license:bsd-3)))
+
 (define-public domainfinder
   (package
     (name "domainfinder")