diff mbox series

[bug#46107,3/6] gnu: Add molequeue.

Message ID 20210125212248.4749-2-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#46107,1/6] gnu: Add spglib. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Kei Kebreau Jan. 25, 2021, 9:22 p.m. UTC
* gnu/packages/chemistry.scm (molequeue): New variable.
---
 gnu/packages/chemistry.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Leo Famulari Jan. 25, 2021, 10:18 p.m. UTC | #1
On Mon, Jan 25, 2021 at 04:22:45PM -0500, Kei Kebreau wrote:
> * gnu/packages/chemistry.scm (molequeue): New variable.

> +    ;; TODO: Enable tests.
> +    (arguments
> +     '(#:tests? #f))

Can you clarify the comment? Even "It's too much work" would be helpful
for future readers.
Kei Kebreau Jan. 26, 2021, 3:21 a.m. UTC | #2
On Mon, 2021-01-25 at 17:18 -0500, Leo Famulari wrote:
> On Mon, Jan 25, 2021 at 04:22:45PM -0500, Kei Kebreau wrote:
> > * gnu/packages/chemistry.scm (molequeue): New variable.
> > +    ;; TODO: Enable tests.
> > +    (arguments
> > +     '(#:tests? #f))
> 
> Can you clarify the comment? Even "It's too much work" would be helpful
> for future readers.

While I was doing this, I went ahead and enabled all but the failing tests.
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 4ac7a90c87..2b54df564e 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -267,6 +267,35 @@  analogy is that InChI is the bar-code for chemistry and chemical structures.")
 biological structures.")
     (license license:expat)))
 
+(define-public molequeue
+  (package
+    (name "molequeue")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/OpenChemistry/molequeue/"
+                           "releases/download/" version "/molequeue-"
+                           version ".tar.bz2"))
+       (sha256
+        (base32
+         "1w1fgxzqrb5yxvpmnc3c9ymnvixy0z1nfafkd9whg9zw8nbgl998"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("qtbase" ,qtbase)))
+    ;; TODO: Enable tests.
+    (arguments
+     '(#:tests? #f))
+    (home-page "https://www.openchemistry.org/projects/molequeue/")
+    (synopsis "Application for coordinating computational jobs")
+    (description "MoleQueue is a system-tray resident desktop application for
+abstracting, managing, and coordinating the execution of tasks both locally and
+ on remote computational resources.  Users can set up local and remote queues
+that describe where the task will be executed.  Each queue can have programs,
+with templates to facilitate the execution of the program.  Input files can be
+staged, and output files collected using a standard interface.")
+    (license license:bsd-3)))
+
 (define with-numpy-1.8
   (package-input-rewriting `((,python2-numpy . ,python2-numpy-1.8))))