diff mbox series

[bug#46096] gnu: make-mingw-w64: Use mirror:// link and fix lint errors.

Message ID 20210125105121.15605-1-lle-bout@zaclys.net
State Accepted
Headers show
Series [bug#46096] gnu: make-mingw-w64: Use mirror:// link and fix lint errors. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

vasilii.smirnov--- via Guix-patches" via Jan. 25, 2021, 10:51 a.m. UTC
* gnu/package/mingw.scm (make-mingw-w64): Use mirror:// link instead of
  hardcoded sourceforge.net. Wrap lines 80 columns to fix lint warning.
---
 gnu/packages/mingw.scm | 49 +++++++++++++++++++++++-------------------
 1 file changed, 27 insertions(+), 22 deletions(-)

Comments

Maxim Cournoyer Feb. 3, 2021, 3:27 p.m. UTC | #1
Hello,

Léo Le Bouter <lle-bout@zaclys.net> writes:

> * gnu/package/mingw.scm (make-mingw-w64): Use mirror:// link instead of
>   hardcoded sourceforge.net. Wrap lines 80 columns to fix lint warning.
> ---
>  gnu/packages/mingw.scm | 49 +++++++++++++++++++++++-------------------
>  1 file changed, 27 insertions(+), 22 deletions(-)
>
> diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
> index b37f6c69bd..58f01ddc9f 100644
> --- a/gnu/packages/mingw.scm
> +++ b/gnu/packages/mingw.scm
> @@ -46,23 +46,26 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
>        (name (string-append "mingw-w64" "-" machine
>                             (if with-winpthreads? "-winpthreads" "")))
>        (version "7.0.0")
> -      (source (origin
> -                (method url-fetch)
> -                (uri (string-append
> -                      "https://sourceforge.net/projects/mingw-w64/files/mingw-w64/"
> -                      "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
> -                (sha256
> -                 (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
> -                (patches
> -                 (search-patches "mingw-w64-6.0.0-gcc.patch"
> -                                 "mingw-w64-dlltool-temp-prefix.patch"
> -                                 "mingw-w64-reproducible-gendef.patch"))))
> +      (source
> +       (origin
> +         (method url-fetch)
> +         (uri (string-append
> +               "mirror://sourceforge/mingw-w64/mingw-w64/"
> +               "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
> +         (sha256
> +          (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
> +         (patches
> +          (search-patches "mingw-w64-6.0.0-gcc.patch"
> +                          "mingw-w64-dlltool-temp-prefix.patch"
> +                          "mingw-w64-reproducible-gendef.patch"))))
>        (native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
> -                       ("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
> +                       ("xbinutils" ,(if xbinutils xbinutils
> +                                         (cross-binutils triplet)))
>                         ,@(if with-winpthreads?
> -                             `(("xlibc" ,(make-mingw-w64 machine
> -                                                         #:xgcc xgcc
> -                                                         #:xbinutils xbinutils)))
> +                             `(("xlibc" ,(make-mingw-w64
> +                                          machine
> +                                          #:xgcc xgcc
> +                                          #:xbinutils xbinutils)))
>                               '())))
>        (build-system gnu-build-system)
>        (search-paths
> @@ -85,9 +88,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
>             (add-before 'configure 'setenv
>               (lambda* (#:key inputs #:allow-other-keys)
>                 (let ((xgcc-core (assoc-ref inputs "xgcc-core"))
> -                     (mingw-headers (string-append (getcwd) "/mingw-w64-headers")))
> +                     (mingw-headers (string-append
> +                                     (getcwd) "/mingw-w64-headers")))
>                   (setenv "CPP"
> -                         (string-append xgcc-core ,(string-append "/bin/" triplet "-cpp")))
> +                         (string-append
> +                          xgcc-core ,(string-append "/bin/" triplet "-cpp")))
>                   (setenv "CROSS_C_INCLUDE_PATH"
>                           (string-append
>                            mingw-headers
> @@ -96,11 +101,11 @@ specified, recurse and return a mingw-w64 with support for winpthreads."
>                            ":" mingw-headers "/defaults/include"
>                            ":" mingw-headers "/direct-x/include"))
>                   (when ,with-winpthreads?
> -                     (let ((xlibc (assoc-ref inputs "xlibc")))
> -                       (setenv "CROSS_LIBRARY_PATH"
> -                               (string-append
> -                                xlibc "/lib" ":"
> -                                xlibc "/" ,triplet "/lib"))))))))
> +                   (let ((xlibc (assoc-ref inputs "xlibc")))
> +                     (setenv "CROSS_LIBRARY_PATH"
> +                             (string-append
> +                              xlibc "/lib" ":"
> +                              xlibc "/" ,triplet "/lib"))))))))
>           #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
>           #:tests? #f ; compiles and includes glibc headers
>           #:strip-binaries? #f))

Pushed as commit 88c635d96a1dfba90278dd9a3c2fcf523c74b55c, thank you.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index b37f6c69bd..58f01ddc9f 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -46,23 +46,26 @@  specified, recurse and return a mingw-w64 with support for winpthreads."
       (name (string-append "mingw-w64" "-" machine
                            (if with-winpthreads? "-winpthreads" "")))
       (version "7.0.0")
-      (source (origin
-                (method url-fetch)
-                (uri (string-append
-                      "https://sourceforge.net/projects/mingw-w64/files/mingw-w64/"
-                      "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
-                (sha256
-                 (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
-                (patches
-                 (search-patches "mingw-w64-6.0.0-gcc.patch"
-                                 "mingw-w64-dlltool-temp-prefix.patch"
-                                 "mingw-w64-reproducible-gendef.patch"))))
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append
+               "mirror://sourceforge/mingw-w64/mingw-w64/"
+               "mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
+         (sha256
+          (base32 "0a5njsa2zw2ssdz10jkb10mhrf3cb8qp9avs89zqmw4n6pzxy85a"))
+         (patches
+          (search-patches "mingw-w64-6.0.0-gcc.patch"
+                          "mingw-w64-dlltool-temp-prefix.patch"
+                          "mingw-w64-reproducible-gendef.patch"))))
       (native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
-                       ("xbinutils" ,(if xbinutils xbinutils (cross-binutils triplet)))
+                       ("xbinutils" ,(if xbinutils xbinutils
+                                         (cross-binutils triplet)))
                        ,@(if with-winpthreads?
-                             `(("xlibc" ,(make-mingw-w64 machine
-                                                         #:xgcc xgcc
-                                                         #:xbinutils xbinutils)))
+                             `(("xlibc" ,(make-mingw-w64
+                                          machine
+                                          #:xgcc xgcc
+                                          #:xbinutils xbinutils)))
                              '())))
       (build-system gnu-build-system)
       (search-paths
@@ -85,9 +88,11 @@  specified, recurse and return a mingw-w64 with support for winpthreads."
            (add-before 'configure 'setenv
              (lambda* (#:key inputs #:allow-other-keys)
                (let ((xgcc-core (assoc-ref inputs "xgcc-core"))
-                     (mingw-headers (string-append (getcwd) "/mingw-w64-headers")))
+                     (mingw-headers (string-append
+                                     (getcwd) "/mingw-w64-headers")))
                  (setenv "CPP"
-                         (string-append xgcc-core ,(string-append "/bin/" triplet "-cpp")))
+                         (string-append
+                          xgcc-core ,(string-append "/bin/" triplet "-cpp")))
                  (setenv "CROSS_C_INCLUDE_PATH"
                          (string-append
                           mingw-headers
@@ -96,11 +101,11 @@  specified, recurse and return a mingw-w64 with support for winpthreads."
                           ":" mingw-headers "/defaults/include"
                           ":" mingw-headers "/direct-x/include"))
                  (when ,with-winpthreads?
-                     (let ((xlibc (assoc-ref inputs "xlibc")))
-                       (setenv "CROSS_LIBRARY_PATH"
-                               (string-append
-                                xlibc "/lib" ":"
-                                xlibc "/" ,triplet "/lib"))))))))
+                   (let ((xlibc (assoc-ref inputs "xlibc")))
+                     (setenv "CROSS_LIBRARY_PATH"
+                             (string-append
+                              xlibc "/lib" ":"
+                              xlibc "/" ,triplet "/lib"))))))))
          #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
          #:tests? #f ; compiles and includes glibc headers
          #:strip-binaries? #f))