diff mbox series

[bug#46069] gnu: Add SystemC.

Message ID 20210124080741.3965-1-andrew@interpretmath.pw
State Accepted
Headers show
Series [bug#46069] gnu: Add SystemC. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Andrew Miloradovsky Jan. 24, 2021, 8:07 a.m. UTC
* gnu/packages/fpga.scm (systemc): New variable.
---
 gnu/packages/fpga.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Nicolas Goaziou Jan. 28, 2021, 1:57 p.m. UTC | #1
Hello,

Andrew Miloradovsky <andrew@interpretmath.pw> writes:

> * gnu/packages/fpga.scm (systemc): New variable.

I applied your patch with the changes detailed below.

> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append
> +                    "https://accellera.org/images/downloads/standards/"
> +                    name "/" name "-" version ".tar.gz"))

I hard-coded "name" since this is what we usually do in packages.

> +    (home-page "https://accellera.org/downloads/standards/systemc")

I changed home-page so it does not point to the Downloads section
directly.

> +    (synopsis "Library for event-driven simulation")

> +    (description "Reference implementation of IEEE 1666-2011.
> +A C++ library for modeling concurrent systems.  

I reworded a bit the description to it starts with full sentences.

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 96ba0026f9..ff03b5270d 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -467,3 +467,32 @@  a hardware description and verification language. ")
     (description "This package provides a VHDL compiler and simulator.")
     (home-page "https://github.com/nickg/nvc")
     (license license:gpl3+)))
+
+(define-public systemc
+  (package
+    (name "systemc")
+    (version "2.3.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://accellera.org/images/downloads/standards/"
+                    name "/" name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0gvv3xmhiwx1izmzy06yslzqzh6ygrgmw53xqfmyvbz5a6ivk0ap"))))
+    (native-inputs `(("perl" ,perl)))
+    (build-system gnu-build-system)
+    (arguments '(#:configure-flags '("--enable-debug")))
+    (home-page "https://accellera.org/downloads/standards/systemc")
+    (synopsis "Library for event-driven simulation")
+    (description "Reference implementation of IEEE 1666-2011.
+A C++ library for modeling concurrent systems.  It provides a notion of timing
+as well as an event-driven simulations environment.  Due to it’s concurrent
+and sequential nature, SystemC allows the description and integration of
+complex hardware and software components.  To some extent, SystemC can be seen
+as a Hardware Description Language. However, unlike VHDL or Verilog, SystemC
+provides sophisticated mechanisms that offer high abstraction levels on
+components interfaces.  This, in turn, facilitates the integration of systems
+using different abstraction levels.")
+    ;; homepages.cae.wisc.edu/~ece734/SystemC/Esperan_SystemC_tutorial.pdf
+    (license license:asl2.0)))