diff mbox series

[bug#46053,2/2] gnu: Add the-question.

Message ID 20210123134656.18353-2-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series Add Ren'py build system | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Jan. 23, 2021, 1:46 p.m. UTC
* gnu/packages/games.scm (the-question): New variable.
---
 gnu/packages/games.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index ee1571e624..8b3a617d0a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -196,6 +196,7 @@ 
   #:use-module (guix build-system meson)
   #:use-module (guix build-system perl)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system renpy)
   #:use-module (guix build-system qt)
   #:use-module (guix build-system scons)
   #:use-module (guix build-system trivial)
@@ -12136,3 +12137,17 @@  game FPS.")
 implemented using ncurses user interface.  An SDL graphical version is also
 available.")
     (license license:gpl3+)))
+
+(define-public the-question
+  (package
+    (name "the-question")
+    (version (package-version renpy))
+    (source (package-source renpy))
+    (build-system renpy-build-system)
+    (arguments
+     '(#:game "the_question/game"))
+    (synopsis "Ren'py example game")
+    (description "The Question is a short game demonstrating the capabilities
+of Ren'py.")
+    (home-page (package-home-page renpy))
+    (license (package-license renpy))))