diff mbox series

[bug#45736,v2,1/3] gnu: python2-pygame-sdl2: Update to renpy-version 7.4.0.

Message ID 20210123095802.9500-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#45736,v2,1/3] gnu: python2-pygame-sdl2: Update to renpy-version 7.4.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Leo Prikler Jan. 23, 2021, 9:58 a.m. UTC
* gnu/packages/game-development.scm (python2-pygame-sdl2): Update to
renpy-version 7.4.0.
---
 gnu/packages/game-development.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index fa7875d077..02e110ec0d 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1062,7 +1062,7 @@  to create fully featured games and multimedia programs in the python language.")
 
 (define-public python2-pygame-sdl2
   (let ((real-version "2.1.0")
-        (renpy-version "7.3.5"))
+        (renpy-version "7.4.0"))
     (package
       (inherit python2-pygame)
       (name "python2-pygame-sdl2")
@@ -1072,13 +1072,13 @@  to create fully featured games and multimedia programs in the python language.")
          (method url-fetch)
          (uri (string-append "https://www.renpy.org/dl/" renpy-version
                              "/pygame_sdl2-" version ".tar.gz"))
-         (sha256 (base32 "1bmr7j9mlsc4czpgw70ld15ymyp4wxrk9hdsqad40wjwdxvvg2dr"))
+         (sha256 (base32 "04hnfy1zbncs8n0m46sh6r8l55l2bz5y08a1birkhlri13f8zc29"))
          (modules '((guix build utils)))
          (snippet
           '(begin
              ;; drop generated sources
              (delete-file-recursively "gen")
-             (delete-file-recursively "gen3")
+             (delete-file-recursively "gen-static")
              #t))))
       (build-system python-build-system)
       (arguments