diff mbox series

[bug#45604] gnu: Add magic-enum.

Message ID 20210120040924.43817-1-joshua.r.marshall.1991@gmail.com
State Accepted
Headers show
Series [bug#45604] gnu: Add magic-enum. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Anadon Jan. 20, 2021, 4:09 a.m. UTC
* gnu/packages/cpp.scm (magic-enum): Added the package definition.
---
 gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Leo Prikler Jan. 20, 2021, 8:14 a.m. UTC | #1
Pushed with some slight changes in the description.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 00e006928e..012640171a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -807,3 +807,27 @@  code will be mixed in with the actual programming logic.  This implementation
 provides a number of utilities to make coding with expected cleaner.")
     (home-page "https://tl.tartanllama.xyz/")
     (license license:cc0)))
+
+(define-public magic-enum
+    (package
+      (name "magic-enum")
+      (version "0.7.2")
+      (home-page "https://github.com/Neargye/magic_enum")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit (string-append "v" version))))
+                (sha256
+                 (base32
+                  "07j5zdf3vkliwrcv6k663k35akn7qp23794sz2mnvkj9hbv9s8cx"))
+                (file-name (git-file-name name version))))
+      (build-system cmake-build-system)
+
+      (native-inputs
+       `(("gcc" ,gcc-9)))
+      (synopsis "C++17 header only library for compile time reflection of enums")
+      (description "C++17 header only library which offers static reflection
+of enums, with to string, from string, and iteration, and relate324    d
+functionality.")
+      (license license:expat)))