diff mbox series

[bug#45908] gnu: xpra: Update to 4.0.6.

Message ID 20210115232058.31809-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#45908] gnu: xpra: Update to 4.0.6. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Jan. 15, 2021, 11:20 p.m. UTC
* gnu/packages/xorg.scm (xpra): Update to 4.0.6.
[inputs]: Add libx264, x265, libvpx to have more encoding options.
---
 gnu/packages/xorg.scm | 9 ++++++---
 1 file changed, 6 insertions(+), 3 deletions(-)

Comments

Efraim Flashner Jan. 18, 2021, 9:54 a.m. UTC | #1
Does this build without the extra inputs? If so, can you split this into
two patches, one for the upgrade and one to add the extra inputs?
Thanks!

On Sat, Jan 16, 2021 at 12:20:58AM +0100, Michael Rohleder wrote:
> * gnu/packages/xorg.scm (xpra): Update to 4.0.6.
> [inputs]: Add libx264, x265, libvpx to have more encoding options.
> ---
>  gnu/packages/xorg.scm | 9 ++++++---
>  1 file changed, 6 insertions(+), 3 deletions(-)
> 
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index 8f84b894f6..900f6c925d 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -23,7 +23,7 @@
>  ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
>  ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
>  ;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
> -;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
> +;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
>  ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
>  ;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
>  ;;;
> @@ -6279,14 +6279,14 @@ basic eye-candy effects.")
>  (define-public xpra
>    (package
>      (name "xpra")
> -    (version "4.0.5")
> +    (version "4.0.6")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://www.xpra.org/src/xpra-"
>                             version ".tar.xz"))
>         (sha256
> -        (base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
> +        (base32 "1s49y2s75a8a70vj0micnmpic5zv1n32yjxy8fkxsqa6j5njyrww"))
>         (patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
>      (build-system python-build-system)
>      ;; see also http://xpra.org/trac/wiki/Dependencies
> @@ -6313,6 +6313,9 @@ basic eye-candy effects.")
>                ("xf86-input-keyboard" ,xf86-input-keyboard)
>                ("python-pillow" ,python-pillow)
>                ;; Optional dependencies.
> +              ("libx264" ,libx264)
> +              ("x265" ,x265)
> +              ("libvpx" ,libvpx)
>                ("python-rencode" ,python-rencode) ; For speed.
>                ("python-numpy" ,python-numpy)
>                ("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.
> -- 
> 2.30.0
> 
> 
> 
>
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 8f84b894f6..900f6c925d 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -23,7 +23,7 @@ 
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2020 Florian Pelz <pelzflorian@pelzflorian.de>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Jean-Baptiste Note <jean-baptiste.note@m4x.org>
 ;;;
@@ -6279,14 +6279,14 @@  basic eye-candy effects.")
 (define-public xpra
   (package
     (name "xpra")
-    (version "4.0.5")
+    (version "4.0.6")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.xpra.org/src/xpra-"
                            version ".tar.xz"))
        (sha256
-        (base32 "11ml66z8vbc0fa567kkmp2j20l5l60aflnkrz5ay8arw3w92nmnz"))
+        (base32 "1s49y2s75a8a70vj0micnmpic5zv1n32yjxy8fkxsqa6j5njyrww"))
        (patches (search-patches "xpra-4.0.1-systemd-run.patch"))))
     (build-system python-build-system)
     ;; see also http://xpra.org/trac/wiki/Dependencies
@@ -6313,6 +6313,9 @@  basic eye-candy effects.")
               ("xf86-input-keyboard" ,xf86-input-keyboard)
               ("python-pillow" ,python-pillow)
               ;; Optional dependencies.
+              ("libx264" ,libx264)
+              ("x265" ,x265)
+              ("libvpx" ,libvpx)
               ("python-rencode" ,python-rencode) ; For speed.
               ("python-numpy" ,python-numpy)
               ("python-pyopengl" ,python-pyopengl) ; Drawing acceleration.