diff mbox series

[bug#45878] gnu: xfconf: Install bash completion.

Message ID 20210115000047.21572-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#45878] gnu: xfconf: Install bash completion. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Jan. 15, 2021, midnight UTC
* gnu/packages/xfce.scm (xfconf)[arguments]: Add install-shell-completions phase.
---
 gnu/packages/xfce.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Ludovic Courtès Jan. 16, 2021, 10:13 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/xfce.scm (xfconf)[arguments]: Add install-shell-completions phase.

Applied, thanks!

Ludo'.
diff mbox series

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index a5c9482c01..00befc517d 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -155,6 +155,13 @@  Xfce Desktop Environment.")
              ;; For the missing '/etc/machine-id'.
              (setenv "DBUS_FATAL_WARNINGS" "0")
              (invoke "dbus-launch" "make" "check")))
+         (add-after 'custom-check 'install-shell-completions
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (etc (string-append out "/etc")))
+               (with-directory-excursion "completions"
+                 (install-file "xfconf-query"
+                               (string-append etc "/bash_completion.d"))))))
          (delete 'check))))
     (native-inputs
      `(("pkg-config" ,pkg-config)