diff mbox series

[bug#45789] gnu: python-mpd2: Update to 3.0.1.

Message ID 20210111153407.32129-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#45789] gnu: python-mpd2: Update to 3.0.1. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Jan. 11, 2021, 3:34 p.m. UTC
* gnu/packages/mpd.scm (python-mpd2): Update to 3.0.1.
[arguments] Use pytest to run the tests. [native-inputs] Add python-pytest.
---
 gnu/packages/mpd.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Leo Famulari Jan. 12, 2021, 10:20 p.m. UTC | #1
On Mon, Jan 11, 2021 at 04:34:07PM +0100, Tanguy Le Carrour wrote:
> * gnu/packages/mpd.scm (python-mpd2): Update to 3.0.1.
> [arguments] Use pytest to run the tests. [native-inputs] Add python-pytest.

Thanks! Pushed as 85e97c96941a2bd283faa71fdb390ff05632f254
Tanguy LE CARROUR Jan. 13, 2021, 7:54 a.m. UTC | #2
Hi Leo,


Excerpts from Leo Famulari's message of January 12, 2021 11:20 pm:
> On Mon, Jan 11, 2021 at 04:34:07PM +0100, Tanguy Le Carrour wrote:
>> * gnu/packages/mpd.scm (python-mpd2): Update to 3.0.1.
>> [arguments] Use pytest to run the tests. [native-inputs] Add python-pytest.
> 
> Thanks! Pushed as 85e97c96941a2bd283faa71fdb390ff05632f254

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 3b76b5502a..0183dab79c 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -285,20 +285,22 @@  information about tracks being played to a scrobbler, such as Libre.FM.")
 (define-public python-mpd2
   (package
     (name "python-mpd2")
-    (version "0.5.5")
+    (version "3.0.1")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "python-mpd2" version))
               (sha256
                (base32
-                "0laypd7h1j14b4vrmiayqlzdsh2j5hc3zv4l0fqvbrbw9y6763ii"))))
+                "0fxssbmnv44m03shjyvbqslc69b0160702j2s0flgvdxjggrnbjj"))))
     (build-system python-build-system)
     (arguments
      '(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda _ (invoke "python" "mpd_test.py"))))))
-    (native-inputs `(("python-mock" ,python-mock)))
+           (lambda _ (invoke "python" "-m" "pytest" "mpd/tests.py"))))))
+    (native-inputs
+     `(("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)))
     (home-page "https://github.com/Mic92/python-mpd2")
     (synopsis "Python MPD client library")
     (description "Python-mpd2 is a Python library which provides a client