diff mbox series

[bug#45604,2/2] Made changes Leo on the ML suggested.

Message ID 20210109024058.68902-3-joshua.r.marshall.1991@gmail.com
State Accepted
Headers show
Series Added magic-enum header-only library as a package. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Anadon Jan. 9, 2021, 2:40 a.m. UTC
---
 gnu/packages/cpp.scm | 12 +++++-------
 1 file changed, 5 insertions(+), 7 deletions(-)

Comments

Maxim Cournoyer May 22, 2022, 4:31 a.m. UTC | #1
tags 45732 +moreinfo
thanks

Hello,

Anadon <joshua.r.marshall.1991@gmail.com> writes:

> ---
>  gnu/packages/cpp.scm | 12 +++++-------
>  1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ff10a4247b..487639c879 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
>                    "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
>                  (modules '((guix build utils)))))
>        (build-system cmake-build-system)
> -
> -      (inputs
> -       `(("gcc" ,gcc-10)))
> -      (synopsis "Header-only C++17 library for reflection for enums")
> -      (description "Static reflection for enums (to string, from string,
> -iteration) for modern C++, work with any enum type without any macro or
> -boilerplate code")
> +      (native-inputs
> +       `(("gcc" ,gcc-9)))
> +      (synopsis "Header-only C++17 library for reflection on enums")
> +      (description "C++17 static reflection for enums, allowing functions like
> + to string, from string, and iteration.")
>        (license license:expat)))

What package is this supposed to affect?  There's no mention of its name
anywhere in the title and it doesn't seem to exist in the repo.

Thanks!

Maxim
Jelle Licht May 29, 2023, 12:18 p.m. UTC | #2
Anadon <joshua.r.marshall.1991@gmail.com> writes:

> ---
>  gnu/packages/cpp.scm | 12 +++++-------
>  1 file changed, 5 insertions(+), 7 deletions(-)
>
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index ff10a4247b..487639c879 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -823,11 +823,9 @@ provides a number of utilities to make coding with expected cleaner.")
>                    "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
>                  (modules '((guix build utils)))))
>        (build-system cmake-build-system)
> -
> -      (inputs
> -       `(("gcc" ,gcc-10)))
> -      (synopsis "Header-only C++17 library for reflection for enums")
> -      (description "Static reflection for enums (to string, from string,
> -iteration) for modern C++, work with any enum type without any macro or
> -boilerplate code")
> +      (native-inputs
> +       `(("gcc" ,gcc-9)))
> +      (synopsis "Header-only C++17 library for reflection on enums")
> +      (description "C++17 static reflection for enums, allowing functions like
> + to string, from string, and iteration.")
>        (license license:expat)))


These changes were taken into account for commit
944aebb46abfaa16321b42a095c729a0d04ae68d as well. Closing
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index ff10a4247b..487639c879 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -823,11 +823,9 @@  provides a number of utilities to make coding with expected cleaner.")
                   "0fmkyh1srkz2bx68agfa30sankg1ig1f95xqp8sp9wj3p9qilsv2"))
                 (modules '((guix build utils)))))
       (build-system cmake-build-system)
-
-      (inputs
-       `(("gcc" ,gcc-10)))
-      (synopsis "Header-only C++17 library for reflection for enums")
-      (description "Static reflection for enums (to string, from string,
-iteration) for modern C++, work with any enum type without any macro or
-boilerplate code")
+      (native-inputs
+       `(("gcc" ,gcc-9)))
+      (synopsis "Header-only C++17 library for reflection on enums")
+      (description "C++17 static reflection for enums, allowing functions like
+ to string, from string, and iteration.")
       (license license:expat)))