diff mbox series

[bug#45523,1/2] gnu: Add libyang

Message ID 20210105105728.11441-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45523,1/2] gnu: Add libyang | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Jan. 5, 2021, 10:57 a.m. UTC
* gnu/packages/networking.scm (libyang): New variable.
---
 gnu/packages/networking.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Leo Famulari Feb. 20, 2021, 6:49 p.m. UTC | #1
On Tue, Jan 05, 2021 at 11:57:27AM +0100, Vincent Legoll wrote:
> * gnu/packages/networking.scm (libyang): New variable.

> +    (home-page "https://github.com/CESNET/libyang")
> +    (synopsis "YANG data modelling language library")
> +    (description "libyang is a YANG data modelling language parser and toolkit
> +written (and providing API) in C.  Current implementation covers YANG 1.0 (RFC
> +6020) as well as YANG 1.1 (RFC 7950).")

I don't really understand what this package does but, I wonder if
networking.scm is the right place for it?
Vincent Legoll Feb. 20, 2021, 7:02 p.m. UTC | #2
Hello,

On Sat, Feb 20, 2021 at 7:49 PM Leo Famulari <leo@famulari.name> wrote:
> I don't really understand what this package does

Neither do I, you should have noticed I don't really know what
I'm doing. Kind of a monkey packager I guess :-)

I hope that's not too frightening.

> but, I wonder if networking.scm is the right place for it?

This looks related to Network Configuration Protocol
(NETCONF), and I had to find a place for it, so I chose
to put it near its user...

WDYT ?
Leo Famulari Feb. 20, 2021, 11:04 p.m. UTC | #3
On Sat, Feb 20, 2021 at 08:02:01PM +0100, Vincent Legoll wrote:
> Neither do I, you should have noticed I don't really know what
> I'm doing. Kind of a monkey packager I guess :-)
> 
> I hope that's not too frightening.

No worries, everybody starts at the beginning!

> This looks related to Network Configuration Protocol
> (NETCONF), and I had to find a place for it, so I chose
> to put it near its user...
> 
> WDYT ?

Alright, makes sense.

I pushed as 55fddf93079fa6e75bbe2d748c6abf8b5897d2c3 after updating
libyang to the latest (thanks to `guix lint` for letting me know about a
new release) and making sure that frrouting still builds.

Sorry these patches took so long to get in...
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index fad917a7c0..fec0341147 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -3508,6 +3508,33 @@  libraries and instead utilizing features provided by the Linux kernel to the
 maximum extent possible.")
     (license license:lgpl2.1+)))
 
+(define-public libyang
+  (package
+    (name "libyang")
+    (version "1.0.184")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/CESNET/libyang")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "00vzka0bdlx1znd06fb0ps0szigdm2x96bpdfx220x79jr9qywhx"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       (list "-DENABLE_BUILD_TESTS=ON" "-DENABLE_LYD_PRIV=ON")))
+    (propagated-inputs `(("pcre" ,pcre)))
+    (native-inputs `(("cmocka" ,cmocka)
+                     ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/CESNET/libyang")
+    (synopsis "YANG data modelling language library")
+    (description "libyang is a YANG data modelling language parser and toolkit
+written (and providing API) in C.  Current implementation covers YANG 1.0 (RFC
+6020) as well as YANG 1.1 (RFC 7950).")
+    (license license:bsd-3)))
+
 (define-public batctl
   (package
    (name "batctl")