diff mbox series

[bug#45670] gnu: slurm: Add old 20.02 version back.

Message ID 20210105083221.15591-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45670] gnu: slurm: Add old 20.02 version back. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Jan. 5, 2021, 8:32 a.m. UTC
* gnu/packages/parallel.scm (slurm-20.02): New variable.
---
 gnu/packages/parallel.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)

Comments

Vincent Legoll Jan. 5, 2021, 8:41 a.m. UTC | #1
Hello,

I took the full tag with the "-1" suffix, maybe
that is not wanted.

WDYT ?
Ludovic Courtès Jan. 7, 2021, 10:34 a.m. UTC | #2
Hi,

Vincent Legoll <vincent.legoll@gmail.com> skribis:

> * gnu/packages/parallel.scm (slurm-20.02): New variable.

Applied.

> I took the full tag with the "-1" suffix, maybe
> that is not wanted.

I think it’s fine.  As long as it’s compatible with the series we had
before (which I think it is), we’re fine.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/parallel.scm b/gnu/packages/parallel.scm
index 3f03792ffd..ef233c2fdf 100644
--- a/gnu/packages/parallel.scm
+++ b/gnu/packages/parallel.scm
@@ -195,6 +195,21 @@  by managing a queue of pending work.")
 ;; <https://slurm.schedmd.com/troubleshoot.html#network>.  Thus, keep older
 ;; releases here.  See also <https://issues.guix.gnu.org/44387>.
 
+(define-public slurm-20.02
+  (package
+    (inherit slurm)
+    (version "20.02.6-1")
+    (source (origin
+              (inherit (package-source slurm))
+              (method url-fetch)
+              (uri (string-append
+                    "https://download.schedmd.com/slurm/slurm-"
+                    version ".tar.bz2"))
+              (sha256
+               (base32
+                "0qj4blfymrd2ry2qmb58l3jbr4jwygc3adcfw7my27rippcijlyc"))))))
+
+
 (define-public slurm-19.05
   (package
     (inherit slurm)