diff mbox series

[bug#45659] gnu: crypto++: Update to 8.4.0.

Message ID 20210104173342.8903-1-vincent.legoll@gmail.com
State Accepted
Headers show
Series [bug#45659] gnu: crypto++: Update to 8.4.0. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Vincent Legoll Jan. 4, 2021, 5:33 p.m. UTC
* gnu/packages/crypto.scm (crypto++): Update to 8.4.0.
---
 gnu/packages/crypto.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Vincent Legoll Jan. 4, 2021, 5:37 p.m. UTC | #1
Hello again,

there is a new version (yes, that close
to the previous 8.3.0 one)

I have the same problem as last time, the
package compiles properly but hangs when
running the test suite (./cryptest.exe using
100% of a CPU core, no syscall)

So can someone test it on bare metal and
then it could be merged if all is well...

Thanks
Efraim Flashner Jan. 5, 2021, 12:43 p.m. UTC | #2
On Mon, Jan 04, 2021 at 06:37:58PM +0100, Vincent Legoll wrote:
> Hello again,
> 
> there is a new version (yes, that close
> to the previous 8.3.0 one)
> 
> I have the same problem as last time, the
> package compiles properly but hangs when
> running the test suite (./cryptest.exe using
> 100% of a CPU core, no syscall)
> 
> So can someone test it on bare metal and
> then it could be merged if all is well...
> 
> Thanks
> -- 
> Vincent Legoll
> 

Tests passed with no problems. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 8226497b81..6683f1cd78 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -717,7 +717,7 @@  data on your platform, so the seed itself will be as random as possible.
 (define-public crypto++
   (package
     (name "crypto++")
-    (version "8.3.0")
+    (version "8.4.0")
     (source (origin
               (method url-fetch/zipbomb)
               (uri (string-append "https://cryptopp.com/cryptopp"
@@ -725,7 +725,7 @@  data on your platform, so the seed itself will be as random as possible.
                                   ".zip"))
               (sha256
                (base32
-                "16jqxvsyjjpyyb89fj2h8mgb0m07vlqvggifbrk7qcqwddda2f6v"))))
+                "16kvfm11xv7j9a3yykzysjgw38a9b7lnc5n5x5h82g395k6ybxf0"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags